LKML Archive on
help / color / mirror / Atom feed
From: Carsten Aulbert <>
Subject: ACPI S3 fails to re-init NIC on Asus A7V
Date: Thu, 27 May 2004 21:57:01 +0200	[thread overview]
Message-ID: <> (raw)

Hi all,

Please consider the following problem:

Home Server (daisy):

Asus A7V board
Duron 650 MHz
Debian sarge (not 100% up2date right now - from March 22nd)
SiS900 (also tried 3Com 3c509-TX-M without a change)

Kernels tried:
2.4.22 (IIRC), 2.6.4, 2.6.4 with acpi-patch 20040311, 2.6.6

Suspending to S3 works fine, resume also (except with the 
onboard-Promise chip, but that's not a big issue), however, trying to 
use the network after resume gives
NETDEV WATCHDOG: eth0: transmit timed out

This also did not help:
/etc/init.d/networking stop
modprobe -r sis900
echo 3 > /proc/acpi/sleep


modprobe sis900
-> module is loaded successfully
/etc/init.d/networking start
-> sets the static routes correctly
pinging a machine on the network yields the same error as before.

(Also tried 3Com 3c509-TXM to no avail)

To spare you about ~1000 lines of output, I've put the output of dmesg, 
lspci -v, acpidmp and an excerpt from /var/log/syslog with enabled 
sis900-debugging here

Does this problem ring any bell, do you need more input from my side? 
I'm currently running out of options and ideas.

TIA for any help


PS: I'm not subscribed but monitor linux.kernel, but feel free to Cc me.

             reply	other threads:[~2004-05-27 19:58 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2004-05-27 19:57 Carsten Aulbert [this message]
2004-05-27 20:15 ` ACPI S3 fails to re-init NIC on Asus A7V Arjan van de Ven
2004-05-28  6:17   ` Carsten Aulbert

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \ \ \ \

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).