LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Robert Hancock <hancockr@shaw.ca>
To: Daniel Barkalow <barkalow@iabervon.org>
Cc: linux-kernel <linux-kernel@vger.kernel.org>,
	netdev@vger.kernel.org, Andrew Morton <akpm@osdl.org>
Subject: Re: forcedeth problems on 2.6.20-rc6-mm3
Date: Mon, 05 Feb 2007 18:35:06 -0600	[thread overview]
Message-ID: <45C7CD3A.808@shaw.ca> (raw)
In-Reply-To: <Pine.LNX.4.64.0702050124320.20138@iabervon.org>

Daniel Barkalow wrote:
> On Sun, 4 Feb 2007, Robert Hancock wrote:
> 
>> Something's busted with forcedeth in 2.6.20-rc6-mm3 for me relative to
>> 2.6.20-rc6. There's no errors in dmesg, but it seems no packets ever get
>> received and so the machine can't get an IP address. I tried reverting all the
>> -mm changes to drivers/net/forcedeth.c, which didn't help. The network
>> controller shares an IRQ with the USB OHCI controller which is receiving
>> interrupts, so it doesn't seem like an interrupt routing problem, though I
>> suppose something wierd could be happening there.
> 
> IIRC, forcedeth tries to use MSI by default. Perhaps the hardware is using 
> it, but the kernel thinks enabling it didn't work? I think there's a 
> module option for forcedeth to disable MSI, which might be worth a try to 
> see if it has any effect.

I must have messed something up when testing before - reverting to 
forcedeth.c from 2.6.20-rc6 does indeed fix the problem. And it doesn't 
seem like no packets at all are received with the -mm3 version (driver 
version 0.60), either - if I do a tcpdump I can get Ethernet packets 
showing up, but I can't ping my router so it seems like something isn't 
getting through properly. With the 2.6.20-rc6 version (driver version 
0.59) it works fine. I switched back and forth between versions and this 
seems repeatable.

I don't think it's MSI related, the CK804 version of these controllers 
doesn't support MSI and the driver shouldn't be trying to use it. I 
tried the MSI and MSI-X disable options on the 0.60 driver, but that 
didn't help.

-- 
Robert Hancock      Saskatoon, SK, Canada
To email, remove "nospam" from hancockr@nospamshaw.ca
Home Page: http://www.roberthancock.com/


  reply	other threads:[~2007-02-06  0:36 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2007-02-05  5:13 Robert Hancock
2007-02-05  5:36 ` Andrew Morton
2007-02-05  5:48   ` Robert Hancock
2007-02-05  6:17     ` Andrew Morton
     [not found]       ` <523e55a00702081326j43de05e3hdd8cf35e946eae9@mail.gmail.com>
2007-02-09  2:57         ` Ayaz Abdulla
2007-02-09 11:58           ` Tobias Diedrich
2007-02-09 12:07             ` Tobias Diedrich
2007-02-09 14:50               ` Jeff Garzik
2007-02-12  6:28                 ` Tobias Diedrich
2007-02-16 14:54                   ` Tobias Diedrich
2007-02-10  4:40           ` Robert Hancock
2007-02-05  6:34 ` Daniel Barkalow
2007-02-06  0:35   ` Robert Hancock [this message]
2007-02-06  0:52     ` Andrew Morton
2007-02-08  5:33       ` Andrew Morton
     [not found] <fa.EU4/Dq38S7AbpiJstT7NwokqTWE@ifi.uio.no>
     [not found] ` <fa.aMmqbeBS9CpIUWfPrgAtORtlXAQ@ifi.uio.no>
     [not found]   ` <fa.d8YTRl6o0OIk8Vvk1QLpyc+bxQU@ifi.uio.no>
     [not found]     ` <fa.XnyZ7qxKkAZ7Yhrg0DdiDmiy6wg@ifi.uio.no>
     [not found]       ` <fa.s8qbnOGnlEinPfyyhT0PZsqiwwE@ifi.uio.no>
     [not found]         ` <fa.6Uftu56OuKdbN+aI/fzLv4opZ/I@ifi.uio.no>
2007-02-20  0:39           ` Robert Hancock
2007-02-19 14:31             ` Ayaz Abdulla

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=45C7CD3A.808@shaw.ca \
    --to=hancockr@shaw.ca \
    --cc=akpm@osdl.org \
    --cc=barkalow@iabervon.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=netdev@vger.kernel.org \
    --subject='Re: forcedeth problems on 2.6.20-rc6-mm3' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).