LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
* error 2 after a compile
@ 2007-02-06 20:00 Thibaud Hulin
  2007-02-06 20:10 ` [patch] " Randy Dunlap
  0 siblings, 1 reply; 4+ messages in thread
From: Thibaud Hulin @ 2007-02-06 20:00 UTC (permalink / raw)
  To: linux-kernel

Hello !
I'm trying to compile a kernel from 2.6.17-10 to 2.6.19 with suspend2.
After this command :
make-kpkg --append-to-version=swsusp2.070206 kernel_image --initrd 
kernel_headers --revision=2.6.1

I obtain :
  Building modules, stage 2.
   MODPOST 1479 modules
WARNING: Can't handle masks in drivers/ide/pci/atiixp:FFFF05
WARNING: "try_to_freeze" [drivers/usb/atm/ueagle-atm.ko] undefined!
make[2]: *** [__modpost] Erreur 1
make[1]: *** [modules] Erreur 2
make[1]: quittant le répertoire « /home/hulin/src/linux-2.6.19 »
make: *** [debian/stamp-build-kernel] Erreur 2

I don't understand the error ?

Thanks for help,
Thibaud.


^ permalink raw reply	[flat|nested] 4+ messages in thread

* [patch] Re: error 2 after a compile
  2007-02-06 20:00 error 2 after a compile Thibaud Hulin
@ 2007-02-06 20:10 ` Randy Dunlap
  2007-02-07 21:13   ` Thibaud Hulin
  0 siblings, 1 reply; 4+ messages in thread
From: Randy Dunlap @ 2007-02-06 20:10 UTC (permalink / raw)
  To: Thibaud Hulin; +Cc: linux-kernel

On Tue, 06 Feb 2007 21:00:54 +0100 Thibaud Hulin wrote:

> Hello !
> I'm trying to compile a kernel from 2.6.17-10 to 2.6.19 with suspend2.
> After this command :
> make-kpkg --append-to-version=swsusp2.070206 kernel_image --initrd 
> kernel_headers --revision=2.6.1
> 
> I obtain :
>   Building modules, stage 2.
>    MODPOST 1479 modules
> WARNING: Can't handle masks in drivers/ide/pci/atiixp:FFFF05
> WARNING: "try_to_freeze" [drivers/usb/atm/ueagle-atm.ko] undefined!
> make[2]: *** [__modpost] Erreur 1
> make[1]: *** [modules] Erreur 2
> make[1]: quittant le répertoire « /home/hulin/src/linux-2.6.19 »
> make: *** [debian/stamp-build-kernel] Erreur 2
> 
> I don't understand the error ?


The driver is missing #include <linux/sched.h>.
Please try the patch below and report back on it.
---

From: Randy Dunlap <randy.dunlap@oracle.com>

Driver needs sched.h for try_to_freeze().

Signed-off-by: Randy Dunlap <randy.dunlap@oracle.com>
---
 drivers/usb/atm/ueagle-atm.c |    1 +
 1 file changed, 1 insertion(+)

--- linux-2619-pv.orig/drivers/usb/atm/ueagle-atm.c
+++ linux-2619-pv/drivers/usb/atm/ueagle-atm.c
@@ -61,6 +61,7 @@
 #include <linux/usb.h>
 #include <linux/firmware.h>
 #include <linux/ctype.h>
+#include <linux/sched.h>
 #include <linux/kthread.h>
 #include <linux/version.h>
 #include <linux/mutex.h>

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [patch] Re: error 2 after a compile
  2007-02-06 20:10 ` [patch] " Randy Dunlap
@ 2007-02-07 21:13   ` Thibaud Hulin
  2007-02-07 21:20     ` Randy Dunlap
  0 siblings, 1 reply; 4+ messages in thread
From: Thibaud Hulin @ 2007-02-07 21:13 UTC (permalink / raw)
  To: Randy Dunlap; +Cc: linux-kernel

Thanks. Before seeing your message, I erase the line with this module in 
the .config, and if worked. However, I must recompile it, because I 
forgot someting for suspend2.
I'd like install your patch. But how can I do it ? Have you join a patch 
sched.h ?


Randy Dunlap a écrit :
> On Tue, 06 Feb 2007 21:00:54 +0100 Thibaud Hulin wrote:
> 
>> Hello !
>> I'm trying to compile a kernel from 2.6.17-10 to 2.6.19 with suspend2.
>> After this command :
>> make-kpkg --append-to-version=swsusp2.070206 kernel_image --initrd 
>> kernel_headers --revision=2.6.1
>>
>> I obtain :
>>   Building modules, stage 2.
>>    MODPOST 1479 modules
>> WARNING: Can't handle masks in drivers/ide/pci/atiixp:FFFF05
>> WARNING: "try_to_freeze" [drivers/usb/atm/ueagle-atm.ko] undefined!
>> make[2]: *** [__modpost] Erreur 1
>> make[1]: *** [modules] Erreur 2
>> make[1]: quittant le répertoire « /home/hulin/src/linux-2.6.19 »
>> make: *** [debian/stamp-build-kernel] Erreur 2
>>
>> I don't understand the error ?
> 
> 
> The driver is missing #include <linux/sched.h>.
> Please try the patch below and report back on it.
> ---
> 
> From: Randy Dunlap <randy.dunlap@oracle.com>
> 
> Driver needs sched.h for try_to_freeze().
> 
> Signed-off-by: Randy Dunlap <randy.dunlap@oracle.com>
> ---
>  drivers/usb/atm/ueagle-atm.c |    1 +
>  1 file changed, 1 insertion(+)
> 
> --- linux-2619-pv.orig/drivers/usb/atm/ueagle-atm.c
> +++ linux-2619-pv/drivers/usb/atm/ueagle-atm.c
> @@ -61,6 +61,7 @@
>  #include <linux/usb.h>
>  #include <linux/firmware.h>
>  #include <linux/ctype.h>
> +#include <linux/sched.h>
>  #include <linux/kthread.h>
>  #include <linux/version.h>
>  #include <linux/mutex.h>
> 
> 



^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [patch] Re: error 2 after a compile
  2007-02-07 21:13   ` Thibaud Hulin
@ 2007-02-07 21:20     ` Randy Dunlap
  0 siblings, 0 replies; 4+ messages in thread
From: Randy Dunlap @ 2007-02-07 21:20 UTC (permalink / raw)
  To: Thibaud Hulin; +Cc: linux-kernel

Thibaud Hulin wrote:
> Thanks. Before seeing your message, I erase the line with this module in 
> the .config, and if worked. However, I must recompile it, because I 
> forgot someting for suspend2.
> I'd like install your patch. But how can I do it ? Have you join a patch 
> sched.h ?

Just apply the patch and rebuild the kernel.
Or edit drivers/usb/atm/ueagle-atm.c and add that one line
and then rebuild the kernel.

Applying patches is covered somewhat in the README file at the
top-level of the kernel source tree and more in the file
Documentation/applying-patches.txt .  A quick summary is:

save the patch from the email as ueagle.patch

cd linux-2.6.19
patch -p1 < ~/ueagle.patch
re-enable the config option if it is still disabled
make all


> Randy Dunlap a écrit :
>> On Tue, 06 Feb 2007 21:00:54 +0100 Thibaud Hulin wrote:
>>
>>> Hello !
>>> I'm trying to compile a kernel from 2.6.17-10 to 2.6.19 with suspend2.
>>> After this command :
>>> make-kpkg --append-to-version=swsusp2.070206 kernel_image --initrd 
>>> kernel_headers --revision=2.6.1
>>>
>>> I obtain :
>>>   Building modules, stage 2.
>>>    MODPOST 1479 modules
>>> WARNING: Can't handle masks in drivers/ide/pci/atiixp:FFFF05
>>> WARNING: "try_to_freeze" [drivers/usb/atm/ueagle-atm.ko] undefined!
>>> make[2]: *** [__modpost] Erreur 1
>>> make[1]: *** [modules] Erreur 2
>>> make[1]: quittant le répertoire « /home/hulin/src/linux-2.6.19 »
>>> make: *** [debian/stamp-build-kernel] Erreur 2
>>>
>>> I don't understand the error ?
>>
>>
>> The driver is missing #include <linux/sched.h>.
>> Please try the patch below and report back on it.
>> ---
>>
>> From: Randy Dunlap <randy.dunlap@oracle.com>
>>
>> Driver needs sched.h for try_to_freeze().
>>
>> Signed-off-by: Randy Dunlap <randy.dunlap@oracle.com>
>> ---
>>  drivers/usb/atm/ueagle-atm.c |    1 +
>>  1 file changed, 1 insertion(+)
>>
>> --- linux-2619-pv.orig/drivers/usb/atm/ueagle-atm.c
>> +++ linux-2619-pv/drivers/usb/atm/ueagle-atm.c
>> @@ -61,6 +61,7 @@
>>  #include <linux/usb.h>
>>  #include <linux/firmware.h>
>>  #include <linux/ctype.h>
>> +#include <linux/sched.h>
>>  #include <linux/kthread.h>
>>  #include <linux/version.h>
>>  #include <linux/mutex.h>

-- 
~Randy

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2007-02-07 21:25 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2007-02-06 20:00 error 2 after a compile Thibaud Hulin
2007-02-06 20:10 ` [patch] " Randy Dunlap
2007-02-07 21:13   ` Thibaud Hulin
2007-02-07 21:20     ` Randy Dunlap

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).