LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
* 2.6.20: Modular fb and logo crash
@ 2007-02-07 14:46 Geert Uytterhoeven
  2007-02-08 16:12 ` Bill Davidsen
  0 siblings, 1 reply; 2+ messages in thread
From: Geert Uytterhoeven @ 2007-02-07 14:46 UTC (permalink / raw)
  To: Linux Frame Buffer Device Development; +Cc: Linux Kernel Development

If you don't have any builtin frame buffer device driver and insmod a frame
buffer device driver, the logo code will still try to display the logo (which
is __initdata). This may cause a crash.

Originally (2.1.x, is it that long ago I used a modular frame buffer device
driver?), this didn't happen because initmem_freed (which no longer exists) was
checked. BTW, there's still a comment in drivers/video/console/fbcon.c about
this.

Anyone else who's seeing this? Anyone with an idea how to fix this?
Moving the logo code to userspace is not considered a solution ;-)

Thanks!

Gr{oetje,eeting}s,

						Geert

--
Geert Uytterhoeven -- Sony Network and Software Technology Center Europe (NSCE)
Geert.Uytterhoeven@sonycom.com ------- The Corporate Village, Da Vincilaan 7-D1
Voice +32-2-7008453 Fax +32-2-7008622 ---------------- B-1935 Zaventem, Belgium

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: 2.6.20: Modular fb and logo crash
  2007-02-07 14:46 2.6.20: Modular fb and logo crash Geert Uytterhoeven
@ 2007-02-08 16:12 ` Bill Davidsen
  0 siblings, 0 replies; 2+ messages in thread
From: Bill Davidsen @ 2007-02-08 16:12 UTC (permalink / raw)
  To: Geert Uytterhoeven
  Cc: Linux Frame Buffer Device Development, Linux Kernel Development

Geert Uytterhoeven wrote:
> If you don't have any builtin frame buffer device driver and insmod a frame
> buffer device driver, the logo code will still try to display the logo (which
> is __initdata). This may cause a crash.
> 
> Originally (2.1.x, is it that long ago I used a modular frame buffer device
> driver?), this didn't happen because initmem_freed (which no longer exists) was
> checked. BTW, there's still a comment in drivers/video/console/fbcon.c about
> this.
> 
> Anyone else who's seeing this? Anyone with an idea how to fix this?
> Moving the logo code to userspace is not considered a solution ;-)

I used to see this when loading from a booted system, but not when the 
modules were in initrd. Don't know if that offers you any help or not. 
Clearly you want the fb built-in so you see the penguins, anyway. ;-D

-- 
Bill Davidsen <davidsen@tmr.com>
   "We have more to fear from the bungling of the incompetent than from
the machinations of the wicked."  - from Slashdot


^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2007-02-08 16:37 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2007-02-07 14:46 2.6.20: Modular fb and logo crash Geert Uytterhoeven
2007-02-08 16:12 ` Bill Davidsen

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).