LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
* Why can't I build a running Kernel?
@ 2007-02-08 18:17 Reg Clemens
  2007-02-08 19:28 ` Jiri Slaby
  0 siblings, 1 reply; 8+ messages in thread
From: Reg Clemens @ 2007-02-08 18:17 UTC (permalink / raw)
  To: Linux Kernel Mailing List

Why can't I build a running Kernel?
I have in the past, but since some time in the 2.6.19 series,
I have got the following series of errors. 
Same thing now with 2.6.20.

I build with:

    make xconfig

changing only the Processor type to Pentium4,
then I

    make bzImage
    make modules
    make modules_install
    make install

Fine everything builds, no errors.
I then try booting, and I get 4 or 5 lines and then

    Unable to access resume device (/dev/sda5)
    mount: could not find filesystem '/dev/root'
    < 4 more lines with setuproot and switchroot >
  
and then

    Kernel panic - not syncing: Attempting to kill init!

Sigh.
What has changed, what do I need to do to get this thing to boot?
-- 
                                        Reg.Clemens
                                        reg@dwf.com



^ permalink raw reply	[flat|nested] 8+ messages in thread

end of thread, other threads:[~2007-02-13 11:41 UTC | newest]

Thread overview: 8+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2007-02-08 18:17 Why can't I build a running Kernel? Reg Clemens
2007-02-08 19:28 ` Jiri Slaby
2007-02-12  8:36   ` albcamus
2007-02-12 11:27     ` Jiri Slaby
2007-02-13  2:16       ` albcamus
2007-02-13 11:41         ` Jiri Slaby
2007-02-13  3:00     ` Tony.Ho
2007-02-13  4:20       ` Tony.Ho

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).