LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
* Problem with 2.6.20 and hostap_cs (Netgear MA401)
@ 2007-02-14 16:59 David G Hamblen
  0 siblings, 0 replies; only message in thread
From: David G Hamblen @ 2007-02-14 16:59 UTC (permalink / raw)
  To: Kernel mailing list

I've got the ieee80211 and hostap code compiled as modules for my MA401 
card,  and the system locks up when I insert the card.  No keyboard, no 
sysrq, no logs after reboot, no nothing. The same configuration works 
fine under 2.6.19.

If I first insert my old 3com 3c589 card, then eject it and rmmod the 
3c589_cs module, the insertion of the MA401 works completely. Preloading 
the modules with insmod or modprobe doesn't help.

Was there a change in the pcmcia or networking initialization code 
between 2.6.19 and 2.6.20?

Here are the relevant modules.

#/sbin/lsmod
Module                  Size  Used by
ieee80211_crypt_wep     5248  0
hostap_cs              59220  3
hostap                110852  1 hostap_cs
ieee80211_crypt         5632  2 ieee80211_crypt_wep,hostap
...
pcmcia                 29280  1 hostap_cs
firmware_class          9664  1 pcmcia
yenta_socket           26892  4
...
rsrc_nonstatic         13248  1 yenta_socket
pcmcia_core            39056  4 \ 
hostap_cs,pcmcia,yenta_socket,rsrc_nonstatic


^ permalink raw reply	[flat|nested] only message in thread

only message in thread, other threads:[~2007-02-14 16:59 UTC | newest]

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2007-02-14 16:59 Problem with 2.6.20 and hostap_cs (Netgear MA401) David G Hamblen

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).