LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: "Florian D." <flockmock@gmx.at>
To: Neil Brown <neilb@suse.de>
Cc: linux-kernel@vger.kernel.org
Subject: Re: cannot add device to partitioned raid6 array
Date: Sun, 01 Apr 2007 11:23:08 +0000	[thread overview]
Message-ID: <460F961C.4050902@gmx.at> (raw)
In-Reply-To: <17935.33905.934360.22271@notabene.brown>

Neil Brown wrote:
> Definitely the cause.  If you really need to add this array, you may
> be able to reduce the usage of the array, then reduce the size of the
> array, then add the drive.
> Depending on how you have partitioned the array, and how you are using
> the partitions, you may just need to reduce the filesystem in the last
> partition, then use *fdisk to resize the partition.  Then something
> like:
> 
>    mdadm --grow --size=243000000 /dev/md_d4
> 
> Is is generally safer to reduce the filesystem too much, resize the
> device, then grow the filesystem up to the size of the device.  That
> way avoids fiddly arithmetic and so reduces the chance of failure.
> 
> NeilBrown
> 

thanks, but I decided to begin from scratch(backup is available ;)
now, all partitions have the same size. creating a raid6 array from 2 drives and hot-adding another
one works now. so this could be regarded as solved.

But when I try to create the array with 3 drives at once, the following strange error appears:

flockmock ~ # mdadm --create /dev/md_d4 --level=6 -a mdp --chunk=32 -n 4 /dev/sda2 /dev/sdb2 
/dev/sdc2 missing
mdadm: RUN_ARRAY failed: Input/output error
mdadm: stopped /dev/md_d4

dmesg shows:
[  484.362525] md: bind<sda2>
[  484.363429] md: bind<sdb2>
[  484.364337] md: bind<sdc2>
[  484.364397] md: md_d4: raid array is not clean -- starting background reconstruction
[  484.365876] raid5: device sdc2 operational as raid disk 2
[  484.365879] raid5: device sdb2 operational as raid disk 1
[  484.365881] raid5: device sda2 operational as raid disk 0
[  484.365884] raid5: cannot start dirty degraded array for md_d4
[  484.365886] RAID5 conf printout:
[  484.365887]  --- rd:4 wd:3
[  484.365889]  disk 0, o:1, dev:sda2
[  484.365891]  disk 1, o:1, dev:sdb2
[  484.365893]  disk 2, o:1, dev:sdc2
[  484.365895] raid5: failed to run raid set md_d4
[  484.365897] md: pers->run() failed ...
[  484.366271] md: md_d4 stopped.
[  484.366303] md: unbind<sdc2>
[  484.366309] md: export_rdev(sdc2)
[  484.366314] md: unbind<sdb2>
[  484.366318] md: export_rdev(sdb2)
[  484.366321] md: unbind<sda2>
[  484.366325] md: export_rdev(sda2)


I just wanted to report that FYI, I will take the first route and wait a little...
cheers, florian

      reply	other threads:[~2007-04-01 11:23 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2007-03-31 23:44 Florian D.
2007-04-01  2:57 ` Neil Brown
2007-04-01  9:25   ` Florian D.
2007-04-01 10:07     ` Neil Brown
2007-04-01 11:23       ` Florian D. [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=460F961C.4050902@gmx.at \
    --to=flockmock@gmx.at \
    --cc=linux-kernel@vger.kernel.org \
    --cc=neilb@suse.de \
    --subject='Re: cannot add device to partitioned raid6 array' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).