LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
* Unable to access PCMCIA with O2 Micro OZ711MP1/MS1
@ 2008-02-05  5:46 Mader, Alexander (N-MSR)
  2008-02-05 13:06 ` Kristoffer Ericson
  0 siblings, 1 reply; 4+ messages in thread
From: Mader, Alexander (N-MSR) @ 2008-02-05  5:46 UTC (permalink / raw)
  To: linux-kernel

Hello,

after contacting linux-pcmcia and some search I am approaching lkml.

There seems to be a problem accessing PCMCIA cards with O2 Micro 
OZ711MP1/MS1 Controller.

On a Fujitsu Siemens Celsius H240 a 2.6.22-3-amd64 kernel from Debian 
testing is in use. PCMCIA utilities for Linux 2.6 version 014-4 are 
installed. I could supply the output of lspci and lshal.

When I insert a CardBus adapter, for instance a CNET CNF401 fast 
ethernet, everything works fine and the adapter becomes available to the 
system -- in this example the NIC with working LAN access. The lspci and 
lshal output then reflects the new hardware.

When I insert a PCMCIA adapter, for instance a 3com 3CCE589EC, a 3com 
3C589C or an compact flash adapter, almost nothing happens: In the case 
of the 3com I just get (dmesg):

	pccard: PCMCIA card inserted into slot 0

In the case of the compact flash adapter at the first insert dmesg gives:

pccard: PCMCIA card inserted into slot 0
cs: memory probe 0x0c0000-0x0fffff: excluding 0xc0000-0xfffff
cs: memory probe 0x60000000-0x60ffffff: excluding 0x60000000-0x60ffffff
cs: memory probe 0x88000000-0x8fffffff: excluding 0x88000000-0x8fffffff
cs: memory probe 0xa0000000-0xa0ffffff: excluding 0xa0000000-0xa0ffffff
cs: memory probe 0xf0300000-0xf03fffff: excluding 0xf0300000-0xf03fffff

Later on dmesg just issues "pccard: PCMCIA card inserted into slot 0" 
when the same card is inserted no matter how often.

In the PCMCIA cases the lshal output doesn't change, but in the lspci 
output the original line changes from:

	BridgeCtl: Parity- SERR- ISA- VGA- MAbort- >Reset+ 16bInt+
	PostWrite+                                  ^^^^^^

to:

	BridgeCtl: Parity- SERR- ISA- VGA- MAbort- >Reset- 16bInt+
	PostWrite+                                  ^^^^^^

In the case of the compact flash adapters neither "modprobe ide_cs" nor 
"modprobe pata_pcmcia" yield anything -- not even in dmesg.

As I do not want to access a SmartCard I did not try the o2scr driver 
from gna.org/projects/o2scr.

If I could supply more data I would like to do so on your request.

Best regards, Alexander.


^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2008-02-06 10:35 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2008-02-05  5:46 Unable to access PCMCIA with O2 Micro OZ711MP1/MS1 Mader, Alexander (N-MSR)
2008-02-05 13:06 ` Kristoffer Ericson
2008-02-06  8:02   ` Resolved (sort of): " Mader, Alexander (N-MSR)
2008-02-06 10:35     ` Kristoffer Ericson

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).