LKML Archive on
help / color / mirror / Atom feed
From: "Jan Beulich" <>
To: <>, <>
Cc: <>, <>,
	<>, <>
Subject: x86: mis-named percpu_xchg_op() after switch to cmpxchg?
Date: Mon, 07 Feb 2011 11:01:09 +0000	[thread overview]
Message-ID: <> (raw)

Other than its name implies, with the switch to use cmpxchg instead of
xchg (commit 8270137a0d50507a5b40f880db636527045b8466) this
macro is no longer suitable for accessing anything that may be written
by other than the local CPU (i.e. anything but the various this_cpu
accessors). Shouldn't it therefore get renamed to eg this_cpu_xchg_op()?


             reply	other threads:[~2011-02-07 11:01 UTC|newest]

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-02-07 11:01 Jan Beulich [this message]
2011-02-07 17:17 ` Christoph Lameter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \ \ \ \ \ \ \ \ \
    --subject='Re: x86: mis-named percpu_xchg_op() after switch to cmpxchg?' \

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).