LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Yinghai Lu <yinghai@kernel.org>
To: Tejun Heo <tj@kernel.org>
Cc: mingo@redhat.com, hpa@zytor.com, tglx@linutronix.de,
rientjes@google.com, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 06/14] x86-32, NUMA: Make @size in init_aloc_remap() represent bytes
Date: Tue, 05 Apr 2011 10:54:45 -0700 [thread overview]
Message-ID: <4D9B5765.2060106@kernel.org> (raw)
In-Reply-To: <1301955840-7246-7-git-send-email-tj@kernel.org>
On 04/04/2011 03:23 PM, Tejun Heo wrote:
> @size variable in init_alloc_remap() is confusing in that it starts as
> number of bytes as its name implies and then becomes number of pages.
> Make it consistently represent bytes.
>
> Signed-off-by: Tejun Heo<tj@kernel.org>
> Cc: Yinghai Lu<yinghai@kernel.org>
> Cc: David Rientjes<rientjes@google.com>
> Cc: Thomas Gleixner<tglx@linutronix.de
> Cc: Ingo Molnar<mingo@redhat.com>
> Cc: "H. Peter Anvin"<hpa@zytor.com>
> ---
> arch/x86/mm/numa_32.c | 18 +++++++-----------
> 1 files changed, 7 insertions(+), 11 deletions(-)
>
> diff --git a/arch/x86/mm/numa_32.c b/arch/x86/mm/numa_32.c
> index 30933fe..99310d2 100644
> --- a/arch/x86/mm/numa_32.c
> +++ b/arch/x86/mm/numa_32.c
> @@ -286,22 +286,19 @@ static __init unsigned long init_alloc_remap(int nid, unsigned long offset)
> size = node_remap_size[nid];
> size += ALIGN(sizeof(pg_data_t), PAGE_SIZE);
>
> - /* convert size to large (pmd size) pages, rounding up */
> - size = (size + LARGE_PAGE_BYTES - 1) / LARGE_PAGE_BYTES;
> - /* now the roundup is correct, convert to PAGE_SIZE pages */
> - size = size * PTRS_PER_PTE;
> + /* align to large page */
> + size = ALIGN(size, LARGE_PAGE_BYTES);
>
> node_pa = memblock_find_in_range(node_start_pfn[nid]<< PAGE_SHIFT,
> (u64)node_end_pfn[nid]<< PAGE_SHIFT,
> - (u64)size<< PAGE_SHIFT,
> - LARGE_PAGE_BYTES);
> + size, LARGE_PAGE_BYTES);
> if (node_pa == MEMBLOCK_ERROR)
> panic("Can not get kva ram\n");
>
> - node_remap_size[nid] = size;
> + node_remap_size[nid] = size>> PAGE_SHIFT;
> node_remap_offset[nid] = offset;
> printk(KERN_DEBUG "Reserving %ld pages of KVA for lmem_map of node %d at %llx\n",
> - size, nid, node_pa>> PAGE_SHIFT);
> + size>> PAGE_SHIFT, nid, node_pa>> PAGE_SHIFT);
>
> /*
> * prevent kva address below max_low_pfn want it on system
> @@ -315,12 +312,11 @@ static __init unsigned long init_alloc_remap(int nid, unsigned long offset)
> * So memblock_x86_reserve_range here, hope we don't run out
> * of that array
> */
> - memblock_x86_reserve_range(node_pa, node_pa + ((u64)size<< PAGE_SHIFT),
> - "KVA RAM");
> + memblock_x86_reserve_range(node_pa, node_pa + size, "KVA RAM");
>
> node_remap_start_pfn[nid] = node_pa>> PAGE_SHIFT;
>
> - return size;
> + return size>> PAGE_SHIFT;
> }
>
> static void init_remap_allocator(int nid)
Acked-by: Yinghai Lu <yinghai@kernel.org>
next prev parent reply other threads:[~2011-04-05 17:55 UTC|newest]
Thread overview: 40+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-04-04 22:23 [PATCHSET tip:x86/mm] x86-32, NUMA: Clean up alloc_remap Tejun Heo
2011-04-04 22:23 ` [PATCH 01/14] x86-32, NUMA: Fix failure condition check in alloc_remap() Tejun Heo
2011-04-05 17:20 ` Yinghai Lu
2011-04-07 2:03 ` [tip:x86/numa] x86-32, numa: " tip-bot for Tejun Heo
2011-04-04 22:23 ` [PATCH 02/14] x86-32, NUMA: Align pgdat size while initializing alloc_remap Tejun Heo
2011-04-05 17:28 ` Yinghai Lu
2011-04-07 2:04 ` [tip:x86/numa] x86-32, numa: " tip-bot for Tejun Heo
2011-04-04 22:23 ` [PATCH 03/14] x86-32, NUMA: Remove redundant top-down alloc code from remap initialization Tejun Heo
2011-04-05 17:37 ` Yinghai Lu
2011-04-07 2:04 ` [tip:x86/numa] x86-32, numa: " tip-bot for Tejun Heo
2011-04-04 22:23 ` [PATCH 04/14] x86-32, NUMA: Reorganize calculate_numa_remap_page() Tejun Heo
2011-04-05 17:42 ` Yinghai Lu
2011-04-07 2:05 ` [tip:x86/numa] x86-32, numa: " tip-bot for Tejun Heo
2011-04-04 22:23 ` [PATCH 05/14] x86-32, NUMA: Rename @node_kva to @node_pa in init_alloc_remap() Tejun Heo
2011-04-05 17:44 ` Yinghai Lu
2011-04-07 2:05 ` [tip:x86/numa] x86-32, numa: " tip-bot for Tejun Heo
2011-04-04 22:23 ` [PATCH 06/14] x86-32, NUMA: Make @size in init_aloc_remap() represent bytes Tejun Heo
2011-04-05 17:54 ` Yinghai Lu [this message]
2011-04-07 2:05 ` [tip:x86/numa] x86-32, numa: " tip-bot for Tejun Heo
2011-04-04 22:23 ` [PATCH 07/14] x86-32, NUMA: Calculate remap size in common code Tejun Heo
2011-04-05 18:04 ` Yinghai Lu
2011-04-07 2:06 ` [tip:x86/numa] x86-32, numa: " tip-bot for Tejun Heo
2011-04-04 22:23 ` [PATCH 08/14] x86-32, NUMA: Make init_alloc_remap() less panicky Tejun Heo
2011-04-07 2:06 ` [tip:x86/numa] x86-32, numa: " tip-bot for Tejun Heo
2011-04-04 22:23 ` [PATCH 09/14] x86-32, NUMA: Move lowmem address space reservation to init_alloc_remap() Tejun Heo
2011-04-05 18:41 ` Yinghai Lu
2011-04-07 2:07 ` [tip:x86/numa] x86-32, numa: " tip-bot for Tejun Heo
2011-04-04 22:23 ` [PATCH 10/14] x86-32, NUMA: Move remapping for remap allocator into init_alloc_remap() Tejun Heo
2011-04-05 18:59 ` Yinghai Lu
2011-04-07 2:07 ` [tip:x86/numa] x86-32, numa: " tip-bot for Tejun Heo
2011-04-04 22:23 ` [PATCH 11/14] x86-32, NUMA: Make pgdat allocation use alloc_remap() Tejun Heo
2011-04-05 19:14 ` Yinghai Lu
2011-04-07 2:08 ` [tip:x86/numa] x86-32, numa: " tip-bot for Tejun Heo
2011-04-04 22:23 ` [PATCH 12/14] x86-32, NUMA: Remove now useless node_remap_offset[] Tejun Heo
2011-04-05 19:15 ` Yinghai Lu
2011-04-07 2:08 ` [tip:x86/numa] x86-32, numa: " tip-bot for Tejun Heo
2011-04-04 22:23 ` [PATCH 13/14] x86-32, NUMA: Remove redundant node_remap_size[] Tejun Heo
2011-04-07 2:08 ` [tip:x86/numa] x86-32, numa: " tip-bot for Tejun Heo
2011-04-04 22:24 ` [PATCH 14/14] x86-32, NUMA: Update remap allocator comments Tejun Heo
2011-04-07 2:09 ` [tip:x86/numa] x86-32, numa: " tip-bot for Tejun Heo
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=4D9B5765.2060106@kernel.org \
--to=yinghai@kernel.org \
--cc=hpa@zytor.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=rientjes@google.com \
--cc=tglx@linutronix.de \
--cc=tj@kernel.org \
--subject='Re: [PATCH 06/14] x86-32, NUMA: Make @size in init_aloc_remap() represent bytes' \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).