LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
* [IPSec] connect: Resource temporarily unavailable
@ 2006-09-12  7:54 gil ran
  0 siblings, 0 replies; 3+ messages in thread
From: gil ran @ 2006-09-12  7:54 UTC (permalink / raw)
  To: linux-kernel

Hi.

I am using kernel 2.6.15, and ipsec-tools 0.6.6.
When the first packets excchange starts IKE phase 1 begins, and the
following error is given:
    connect: Resource temporarily unavailable

On 24 Feb 2004 Felipe Alfaro Solana wrote about this issue:
http://lkml.org/lkml/fancy/2004/2/24/73

At the time the answer send by David S. Miller was:
> Known behavior, and it's unlikely to be changing soon as doing the correct
> thing here requires a lot of work.
( http://lkml.org/lkml/2004/2/24/159 )

Is there any progress about this issue?

Gil Ran

Please CC to me, I am not on the list. Thanks.

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [IPSec] connect: Resource temporarily unavailable
  2004-02-24 13:48 Felipe Alfaro Solana
@ 2004-02-24 18:10 ` David S. Miller
  0 siblings, 0 replies; 3+ messages in thread
From: David S. Miller @ 2004-02-24 18:10 UTC (permalink / raw)
  To: Felipe Alfaro Solana; +Cc: linux-kernel, netdev

On Tue, 24 Feb 2004 14:48:41 +0100
Felipe Alfaro Solana <felipe_alfaro@linuxmail.org> wrote:

> connect: Resource temporarily unavailable

Known behavior, and it's unlikely to be changing soon as doing the correct
thing here requires a lot of work.

^ permalink raw reply	[flat|nested] 3+ messages in thread

* [IPSec] connect: Resource temporarily unavailable
@ 2004-02-24 13:48 Felipe Alfaro Solana
  2004-02-24 18:10 ` David S. Miller
  0 siblings, 1 reply; 3+ messages in thread
From: Felipe Alfaro Solana @ 2004-02-24 13:48 UTC (permalink / raw)
  To: linux-kernel; +Cc: netdev

When using Racoon to manage SAs between two IPv4/IPSec hosts running 2.6
kernels and IPSec in transport mode with mandatory ESP/AH support, the
first packet exchange between both hosts triggers IKE Phase 1 but,
instead of queueing the userspace packet that triggered the IKE exchange
until IKE Phase 2 has ended and the SA has been established, userspace
receives the following errpr:

connect: Resource temporarily unavailable

Any further attempt to exchange packets between both hosts succeeds
after a while, (once the IKE Phase 2 ends and the SA has been correctly
established).

Is this a bug? Shouldn't the kernel queue (hold) userspace packets until
IKE Phase 2 has completed (either successfully or with error)? Why am I
receiving "connect: Resource temporarily unavailable" error when there
is no SA set up?

This is reproducible by either pinging or telnetting the other peer or
the IPSec link. Both hosts are running 2.6.3 kernels and ipsec-tools
0.2.2. Once IKE Phase 2 ends, ping and telnet work with no error and
tcpdump reveals that AH/ESP protocols are being used.


^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2006-09-12  7:54 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2006-09-12  7:54 [IPSec] connect: Resource temporarily unavailable gil ran
  -- strict thread matches above, loose matches on Subject: below --
2004-02-24 13:48 Felipe Alfaro Solana
2004-02-24 18:10 ` David S. Miller

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).