LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Alex Dowad <alexinbeijing@gmail.com>
To: David Rientjes <rientjes@google.com>, josh@joshtriplett.org
Cc: linux-kernel@vger.kernel.org,
	Andrew Morton <akpm@linux-foundation.org>,
	Oleg Nesterov <oleg@redhat.com>,
	Peter Zijlstra <peterz@infradead.org>,
	"Kirill A. Shutemov" <kirill.shutemov@linux.intel.com>,
	Rik van Riel <riel@redhat.com>,
	Vladimir Davydov <vdavydov@parallels.com>
Subject: Re: [PATCH 01/32] do_fork(): Rename 'stack_size' argument to reflect actual use
Date: Sat, 14 Mar 2015 19:14:03 +0200	[thread overview]
Message-ID: <55046C5B.6020308@gmail.com> (raw)
In-Reply-To: <alpine.DEB.2.10.1503131619500.7827@chino.kir.corp.google.com>


On 14/03/15 01:21, David Rientjes wrote:
> On Fri, 13 Mar 2015, josh@joshtriplett.org wrote:
>
>> On Fri, Mar 13, 2015 at 08:04:16PM +0200, Alex Dowad wrote:
>>> The 'stack_size' argument is never used to pass a stack size. It's only used when
>>> forking a kernel thread, in which case it is an argument which should be passed
>>> to the 'main' function which the kernel thread executes. Hence, rename it to
>>> 'kthread_arg'.
>> That's not the only use of stack_size.  Take a look at the clone2 system
>> call (very minimally documented in the clone manpage) and the
>> implementation of copy_thread on ia64, which does use stack_size in the
>> non-kthread path.
>>
> Exactly, and it seems like Alex just disregarded this early feedback when
> this was first raised that suggested it just be named "arg" and to comment
> the individual usage in the functions that get called with the formal.
David, just to clarify: your feedback was much appreciated and has not 
been disregarded. I am still not convinced that "arg" is the best name 
for the argument now called "stack_start"; I think there must be a 
better name, but can't think of what it is. If you or others have more 
suggestions, that would be helpful.

Because of the uncertainty, I have avoided modifying that part of the 
code, and have focused on what seems like a more clear and unequivocal 
win for readability: renaming the "stack_size" argument. Josh Triplett 
kindly pointed out that "stack_size" is in fact used for a stack size 
when processing one particular syscall on one arch. However, rather than 
naming the args according to that rare case, it seems like a better idea 
to name them according to the 99.9% case, and add a comment mentioning 
the 0.1% case.

Or maybe "arg1" and "arg2" are really best. If the other maintainers 
concur with that, I would be happy to rewrite this set of patches 
accordingly.

Again, I appreciate your feedback and hope to receive more (if you have 
more to give).

Thanks,
Alex Dowad

  reply	other threads:[~2015-03-14 17:14 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-03-13 18:04 Alex Dowad
2015-03-13 18:04 ` [PATCH 02/32] alpha: copy_thread(): rename 'arg' argument to 'kthread_arg' Alex Dowad
2015-03-13 18:04 ` [PATCH 03/32] arc: " Alex Dowad
2015-03-25 11:47   ` Vineet Gupta
2015-03-25 12:34     ` Alex Dowad
2015-03-25 12:37       ` Vineet Gupta
2015-03-13 18:04 ` [PATCH 04/32] arm: copy_thread(): rename 'stk_sz' " Alex Dowad
2015-03-13 18:04 ` [PATCH 05/32] arm64: " Alex Dowad
2015-03-13 18:04 ` [PATCH 06/32] avr32: copy_thread(): rename 'arg' " Alex Dowad
2015-03-16  7:03   ` Hans-Christian Egtvedt
2015-03-16  8:18     ` [PATCHv2 " Alex Dowad
2015-03-16  9:52       ` Hans-Christian Egtvedt
2015-03-13 18:04 ` [PATCH 07/32] blackfin: copy_thread(): rename 'topstk' " Alex Dowad
2015-03-13 18:04 ` [PATCH 08/32] c6x: copy_thread(): rename 'ustk_size' " Alex Dowad
2015-03-13 18:04 ` [PATCH 09/32] cris/arch-v10: copy_thread(): rename 'arg' " Alex Dowad
2015-03-25 11:20   ` Jesper Nilsson
2015-03-13 18:04 ` [PATCH 10/32] cris/arch-v32: " Alex Dowad
2015-03-25 11:20   ` Jesper Nilsson
2015-03-13 18:18 ` [PATCH 01/32] do_fork(): Rename 'stack_size' argument to reflect actual use Aaron Tomlin
2015-03-13 23:04 ` josh
2015-03-13 23:21   ` David Rientjes
2015-03-14 17:14     ` Alex Dowad [this message]
2015-03-14 16:19   ` Alex Dowad
2015-03-14 17:30     ` Geert Uytterhoeven

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=55046C5B.6020308@gmail.com \
    --to=alexinbeijing@gmail.com \
    --cc=akpm@linux-foundation.org \
    --cc=josh@joshtriplett.org \
    --cc=kirill.shutemov@linux.intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=oleg@redhat.com \
    --cc=peterz@infradead.org \
    --cc=riel@redhat.com \
    --cc=rientjes@google.com \
    --cc=vdavydov@parallels.com \
    --subject='Re: [PATCH 01/32] do_fork(): Rename '\''stack_size'\'' argument to reflect actual use' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).