LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: "Winkler, Tomas" <email@example.com>
To: Jarkko Sakkinen <firstname.lastname@example.org>
Cc: Jason Gunthorpe <email@example.com>,
"Usyskin, Alexander" <firstname.lastname@example.org>,
Subject: RE: [PATCH] tpm: separate cmd_ready/go_idle from runtime_pm
Date: Wed, 23 May 2018 13:48:17 +0000 [thread overview]
Message-ID: <5B8DA87D05A7694D9FA63FD143655C1B9D8A1269@hasmsx109.ger.corp.intel.com> (raw)
> On Tue, May 22, 2018 at 09:27:46AM +0000, Winkler, Tomas wrote:
> > >
> > > On Wed, May 16, 2018 at 10:46:00PM +0300, Tomas Winkler wrote:
> > > > New wrappers are added tpm_cmd_ready() and tpm_go_idle()
> > > > to streamline tpm_try_transmit code. TPM_TRANSMIT_UNLOCKED flag
> > > abused
> > > > to resolve tpm spaces recursive calls to tpm_transmit().
> > >
> > > This looks good and all but I don't think we want to abuse anything
> > > in the driver code, do we?
> > It's not abuse just the flag UNLOCKED is not really named correctly I
> > think this has to be backported so wanted to do less invasive change.
> It should be renamed anyway and possible merge conflicts are not hard to
> sort out in this change. Can you rename it as SPACE?
Not sure, I believe UNLOCKED is still better name than SPACE, I'm not sure this is
Do you also want to remove TPM_TRANSMIT_RAW?
clk_enable is handling its own anti recursion counter 'data->clkrun_enabled'
but it should be all handled under one flag I guess.
> Right, and even without rename this will probably cause merge conflicts at
> least in v4.4 an v4.9 since in-kernel RM landed in v4.12, so not much gain not
> do the rename :-)
I belive we should do minimal change and the big cleanup after that.
Not sure, I believe UNLOCKED is still better name than SPACE even it wasn't the original intention.
No the SPACE is the issue, but any recursion call into tpm_transmit. A bigger change is needed
and rename to SPACE would be just another intermediat change.
next prev parent reply other threads:[~2018-05-23 13:48 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-05-16 19:46 Tomas Winkler
2018-05-22 9:17 ` Jarkko Sakkinen
2018-05-22 9:27 ` Winkler, Tomas
2018-05-23 13:16 ` Jarkko Sakkinen
2018-05-23 13:48 ` Winkler, Tomas [this message]
2018-05-30 10:50 ` Jarkko Sakkinen
2018-05-30 10:52 ` Winkler, Tomas
2018-05-30 23:37 ` Jarkko Sakkinen
2018-06-06 11:01 ` Winkler, Tomas
2018-06-07 10:24 ` Jarkko Sakkinen
2018-06-07 11:03 ` Winkler, Tomas
2018-06-07 14:26 ` Jarkko Sakkinen
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--subject='RE: [PATCH] tpm: separate cmd_ready/go_idle from runtime_pm' \
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).