LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Randy Dunlap <rdunlap@infradead.org>
To: Takashi Iwai <tiwai@suse.de>
Cc: alsa-devel@alsa-project.org, LKML <linux-kernel@vger.kernel.org>
Subject: Re: HDA codec problem
Date: Fri, 20 Aug 2021 07:43:26 -0700	[thread overview]
Message-ID: <775793c5-979a-169b-3634-e08e62284b36@infradead.org> (raw)
In-Reply-To: <s5hczq86wac.wl-tiwai@suse.de>

On 8/20/21 7:11 AM, Takashi Iwai wrote:
> On Fri, 20 Aug 2021 15:54:51 +0200,
> Randy Dunlap wrote:
>>
>> On 8/19/21 11:44 PM, Takashi Iwai wrote:
>>> On Fri, 20 Aug 2021 07:08:34 +0200,
>>> Randy Dunlap wrote:
>>>>
>>>> Hi,
>>>>
>>>> I am having problems getting audio working on my computer:
>>>>
>>>> 00:1f.3 Audio device: Intel Corporation Device f1c8
>>>>
>>>> I did an internet search that said that I would need 5.13 or later to
>>>> have support for this device.
>>>
>>> The above is Cometlake-H, and it pretty much depends on the machine
>>> configuration.
>>>
>>>> openSUSE 15.3 kernel 5.3.18-59.19-default says:
>>>>
>>>> snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC233: line_outs=1 (0x1b/0x0/0x0/0x0/0x0) type:line
>>>> snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
>>>> snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
>>>> snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
>>>> snd_hda_codec_realtek hdaudioC0D0:    inputs:
>>>> snd_hda_codec_realtek hdaudioC0D0:      Mic=0x1a
>>>> snd_hda_codec_realtek hdaudioC0D0:      Mic=0x19
>>>>
>>>> but produces no sound output.
>>>
>>> FWIW, openSUSE Leap 15.3 kernel is based on 5.3 but got tons of
>>> backports, hence its HD-audio part is almost equivalent with 5.13 or
>>> later kernel (except for the recently changed mute-LED handling --
>>> which must be irrelevant with your problem).
>>>
>>> The above indicates that the codec is detected and set up.  The rest
>>> part is often some vendor-specific quirks.  For that, details are
>>> missing completely.  At best please give alsa-info.sh output (run the
>>> script with --no-upload and attach the output).
>>>
>>
>> Oh, of course. Now attached.
> 
> I see that the Headphone mixer switch is off by some reason.
> But it should have been toggled by PulseAudio.
> 
> You can test like:
>    amixer -c0 set "Headphone" unmute

Simple mixer control 'Headphone',0
   Capabilities: pvolume pswitch
   Playback channels: Front Left - Front Right
   Limits: Playback 0 - 87
   Mono:
   Front Left: Playback 87 [100%] [0.00dB] [on]
   Front Right: Playback 87 [100%] [0.00dB] [on]


> Also, just to be sure: did you install both pulseaudio and pipewire?
> They may conflict.

Yes. pipewire is now gone.

Still no sound but I might need to restart...

Thanks!

-- 
~Randy


  reply	other threads:[~2021-08-20 14:43 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-08-20  5:08 Randy Dunlap
2021-08-20  6:44 ` Takashi Iwai
2021-08-20 13:54   ` Randy Dunlap
2021-08-20 14:11     ` Takashi Iwai
2021-08-20 14:43       ` Randy Dunlap [this message]
2021-08-21 19:14         ` Randy Dunlap

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=775793c5-979a-169b-3634-e08e62284b36@infradead.org \
    --to=rdunlap@infradead.org \
    --cc=alsa-devel@alsa-project.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=tiwai@suse.de \
    --subject='Re: HDA codec problem' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).