LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: "Patrick Ale" <patrick.ale@gmail.com>
To: linux-kernel@vger.kernel.org
Subject: Re: Boot problems with pata_via driver
Date: Mon, 29 Jan 2007 22:18:44 +0100	[thread overview]
Message-ID: <8d158e1f0701291318w6de001d4xe5cb86f7c0ad205f@mail.gmail.com> (raw)
In-Reply-To: <8d158e1f0701291301q18040b76t162bf09cca16660b@mail.gmail.com>

On 1/29/07, Patrick Ale <patrick.ale@gmail.com> wrote:

A lot of crap. And i am a fruitcake, nutter, headcase.

*sigh* sorry for wasting your time, I found my problem.
Since I thought libata worked like my old ata drivers and 2.6.19 was
booting well, I reconfigured my kernel source and changed
CONFIG_BLK_DEV=y to CONFIG_BLK_DEV=m, since I genuinely thought I
wouldnt need additional disk drivers since I never needed them for
IDE. I compiled the kernel and all but never copied over the bzImage
over to /boot/

Now, I grabbed the config from 2.6.19 , copied it to 2.6.20, ran a
make oldconfig && make && make_modules and copied the bzImage to
/boot/. Of course, the 2.6.20 image I try to boot DOES contain the
CONFIG_BLK_DEV=m , so it wont find any disks, since the module is not
active (I dont use ramdisks).

I reconfigured 2.6.20 with CONFIG_BLK_DEV=y , and its working now.
idiot I am, what else can I say.

Again, sorry for wasting your time.

      reply	other threads:[~2007-01-29 21:18 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2007-01-28 11:47 Patrick Ale
2007-01-28 23:11 ` Adrian Bunk
     [not found]   ` <8d158e1f0701282330o3591a226lb664644ffdb025f0@mail.gmail.com>
2007-01-29  7:32     ` Patrick Ale
2007-01-29 20:53       ` Patrick Ale
2007-01-29 21:01         ` Patrick Ale
2007-01-29 21:18           ` Patrick Ale [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=8d158e1f0701291318w6de001d4xe5cb86f7c0ad205f@mail.gmail.com \
    --to=patrick.ale@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --subject='Re: Boot problems with pata_via driver' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).