LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
* [LIBATA] drives not detected
@ 2007-02-15  8:48 Patrick Ale
  2007-02-15  8:52 ` Patrick Ale
  0 siblings, 1 reply; 2+ messages in thread
From: Patrick Ale @ 2007-02-15  8:48 UTC (permalink / raw)
  To: linux-kernel

Good morning all,

Yesterday I replaced a Sil680 PCI add-on card for a Promise 2027x PCI
add-on card.


Now, when I boot up, I miss two drives, exactly the two connected to
this promise card.
I have another onboard Promise controller which works just fine, so
the driver gets loaded properly, and since i see all my other disks
but these two I think we can rule out a misconfiguration of the kernel
config this time ;-)

This is a snippet from my dmesg

pata_pdc2027x 0000:00:0b.0: version 0.74-ac5
ACPI: PCI Interrupt 0000:00:0b.0[A] -> GSI 19 (level, low) -> IRQ 20
pata_pdc2027x 0000:00:0b.0: PLL input clock 16799 kHz
ata7: PATA max UDMA/133 cmd 0xf98a17c0 ctl 0xf98a1fda bmdma 0xf98a1000 irq 20
ata8: PATA max UDMA/133 cmd 0xf98a15c0 ctl 0xf98a1dda bmdma 0xf98a1008 irq 20
scsi7 : pata_pdc2027x
scsi8 : pata_pdc2027x
ATA: abnormal status 0x8 on port 0xf98a15df


As you can see, scsi8 gives an abnormal status, which as we got
pointed out this week is just a cosmetic error for "No drive
attached/detected" and it's very right in that finding.

But what about scsi7? no warning/error about no disks being attached
nor a disk detection.

To state the obvious: I see the disks being detected by the Promise
BIOS when I boot the system,Primaiy master and Primaiy slave.

Here is the lspci -vvv regarding the controller

00:0b.0 Mass storage controller: Promise Technology, Inc. 20269 (rev
02) (prog-if 85)
        Subsystem: Promise Technology, Inc. Ultra133TX2
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66MHz+ UDF- FastB2B- ParErr- DEVSEL=slow >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 32 (1000ns min, 4500ns max), Cache Line Size: 32 bytes
        Interrupt: pin A routed to IRQ 20
        Region 0: I/O ports at 9400 [size=8]
        Region 1: I/O ports at 9800 [size=4]
        Region 2: I/O ports at 9c00 [size=8]
        Region 3: I/O ports at a000 [size=4]
        Region 4: I/O ports at a400 [size=16]
        Region 5: Memory at eb000000 (32-bit, non-prefetchable) [size=16K]
        [virtual] Expansion ROM at ea100000 [disabled] [size=16K]
        Capabilities: [60] Power Management version 1
                Flags: PMEClk- DSI+ D1+ D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-



Take care all!

Patrick

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [LIBATA] drives not detected
  2007-02-15  8:48 [LIBATA] drives not detected Patrick Ale
@ 2007-02-15  8:52 ` Patrick Ale
  0 siblings, 0 replies; 2+ messages in thread
From: Patrick Ale @ 2007-02-15  8:52 UTC (permalink / raw)
  To: linux-kernel

On 2/15/07, Patrick Ale <patrick.ale@gmail.com> wrote:
> Good morning all,

> Now, when I boot up, I miss two drives, exactly the two connected to
> this promise card.
> I have another onboard Promise controller which works just fine, so
> the driver gets loaded properly, and since i see all my other disks
> but these two I think we can rule out a misconfiguration of the kernel
> config this time ;-)

It would be nice if I'd also mention the kernel I use eh.
It's linux-2.6-git8


Patrick

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2007-02-15  8:52 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2007-02-15  8:48 [LIBATA] drives not detected Patrick Ale
2007-02-15  8:52 ` Patrick Ale

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).