LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
* [PATCH] docs: Set upper limit of docutils (<0.17)
@ 2021-07-27 10:23 Akira Yokosawa
  2021-08-10  9:16 ` [PATCH v2] docs: sphinx-requirements: Move sphinx_rtd_theme to top Akira Yokosawa
  0 siblings, 1 reply; 4+ messages in thread
From: Akira Yokosawa @ 2021-07-27 10:23 UTC (permalink / raw)
  To: Jonathan Corbet
  Cc: Mauro Carvalho Chehab, linux-doc, linux-kernel, Akira Yokosawa

sphinx_rtd_theme 0.5.2 has "docutils<0.17" in its requirements.
docutils 0.17 was released this April and caused regression in
sphinx_rtd_theme 0.5.1 [1].
Put the same limit in sphinx/requirements.txt.

[1]: https://github.com/readthedocs/sphinx_rtd_theme/issues/1112

Signed-off-by: Akira Yokosawa <akiyks@gmail.com>
Cc: Mauro Carvalho Chehab <mchehab@kernel.org>
---
 Documentation/sphinx/requirements.txt | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/Documentation/sphinx/requirements.txt b/Documentation/sphinx/requirements.txt
index 489f6626de67..f8974875c0ec 100644
--- a/Documentation/sphinx/requirements.txt
+++ b/Documentation/sphinx/requirements.txt
@@ -1,3 +1,3 @@
-docutils
+docutils<0.17
 Sphinx==2.4.4
 sphinx_rtd_theme
-- 
2.17.1


^ permalink raw reply	[flat|nested] 4+ messages in thread

* [PATCH v2] docs: sphinx-requirements: Move sphinx_rtd_theme to top
  2021-07-27 10:23 [PATCH] docs: Set upper limit of docutils (<0.17) Akira Yokosawa
@ 2021-08-10  9:16 ` Akira Yokosawa
  2021-08-10  9:22   ` Mauro Carvalho Chehab
  2021-08-12 15:16   ` Jonathan Corbet
  0 siblings, 2 replies; 4+ messages in thread
From: Akira Yokosawa @ 2021-08-10  9:16 UTC (permalink / raw)
  To: Jonathan Corbet
  Cc: Mauro Carvalho Chehab, linux-doc, linux-kernel, Akira Yokosawa

sphinx_rtd_theme 0.5.2 has "docutils<0.17" in its requirements.
docutils 0.17 released this April caused regression in
sphinx_rtd_theme 0.5.1 [1].

By removing docutils and moving sphinx_rtd_theme before Sphinx in
requirements.txt, the requirement of "docutils<0.17" can be met
naturally.

[1]: https://github.com/readthedocs/sphinx_rtd_theme/issues/1112

Signed-off-by: Akira Yokosawa <akiyks@gmail.com>
Cc: Mauro Carvalho Chehab <mchehab@kernel.org>
---
Hi,

It is better to keep requirements as minimal as possible.
Let's leave the dependency to the sphinx_rtd_theme package.

Changes in v1 [2] -> v2:

    o Remove docutils entry.
    o Move sphinx_rtd_theme to top.
    o Adjust patch title.

[2]: https://lore.kernel.org/linux-doc/974babfe-540f-40e4-38b3-ab294ba70ccc@gmail.com/

        Thanks, Akira
--
 Documentation/sphinx/requirements.txt | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/Documentation/sphinx/requirements.txt b/Documentation/sphinx/requirements.txt
index 489f6626de67..9a35f50798a6 100644
--- a/Documentation/sphinx/requirements.txt
+++ b/Documentation/sphinx/requirements.txt
@@ -1,3 +1,2 @@
-docutils
-Sphinx==2.4.4
 sphinx_rtd_theme
+Sphinx==2.4.4
-- 
2.17.1



^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH v2] docs: sphinx-requirements: Move sphinx_rtd_theme to top
  2021-08-10  9:16 ` [PATCH v2] docs: sphinx-requirements: Move sphinx_rtd_theme to top Akira Yokosawa
@ 2021-08-10  9:22   ` Mauro Carvalho Chehab
  2021-08-12 15:16   ` Jonathan Corbet
  1 sibling, 0 replies; 4+ messages in thread
From: Mauro Carvalho Chehab @ 2021-08-10  9:22 UTC (permalink / raw)
  To: Akira Yokosawa; +Cc: Jonathan Corbet, linux-doc, linux-kernel

Em Tue, 10 Aug 2021 18:16:32 +0900
Akira Yokosawa <akiyks@gmail.com> escreveu:

> sphinx_rtd_theme 0.5.2 has "docutils<0.17" in its requirements.
> docutils 0.17 released this April caused regression in
> sphinx_rtd_theme 0.5.1 [1].
> 
> By removing docutils and moving sphinx_rtd_theme before Sphinx in
> requirements.txt, the requirement of "docutils<0.17" can be met
> naturally.
> 
> [1]: https://github.com/readthedocs/sphinx_rtd_theme/issues/1112
> 
> Signed-off-by: Akira Yokosawa <akiyks@gmail.com>
> Cc: Mauro Carvalho Chehab <mchehab@kernel.org>

This was needed when the minimal version was 1.x, but I guess
we can just get rid of docutils explicit dependency nowadays.

Acked-by: Mauro Carvalho Chehab <mchehab@kernel.org>

> ---
> Hi,
> 
> It is better to keep requirements as minimal as possible.
> Let's leave the dependency to the sphinx_rtd_theme package.
> 
> Changes in v1 [2] -> v2:
> 
>     o Remove docutils entry.
>     o Move sphinx_rtd_theme to top.
>     o Adjust patch title.
> 
> [2]: https://lore.kernel.org/linux-doc/974babfe-540f-40e4-38b3-ab294ba70ccc@gmail.com/
> 
>         Thanks, Akira
> --
>  Documentation/sphinx/requirements.txt | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
> 
> diff --git a/Documentation/sphinx/requirements.txt b/Documentation/sphinx/requirements.txt
> index 489f6626de67..9a35f50798a6 100644
> --- a/Documentation/sphinx/requirements.txt
> +++ b/Documentation/sphinx/requirements.txt
> @@ -1,3 +1,2 @@
> -docutils
> -Sphinx==2.4.4
>  sphinx_rtd_theme
> +Sphinx==2.4.4



Thanks,
Mauro

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH v2] docs: sphinx-requirements: Move sphinx_rtd_theme to top
  2021-08-10  9:16 ` [PATCH v2] docs: sphinx-requirements: Move sphinx_rtd_theme to top Akira Yokosawa
  2021-08-10  9:22   ` Mauro Carvalho Chehab
@ 2021-08-12 15:16   ` Jonathan Corbet
  1 sibling, 0 replies; 4+ messages in thread
From: Jonathan Corbet @ 2021-08-12 15:16 UTC (permalink / raw)
  To: Akira Yokosawa
  Cc: Mauro Carvalho Chehab, linux-doc, linux-kernel, Akira Yokosawa

Akira Yokosawa <akiyks@gmail.com> writes:

> sphinx_rtd_theme 0.5.2 has "docutils<0.17" in its requirements.
> docutils 0.17 released this April caused regression in
> sphinx_rtd_theme 0.5.1 [1].
>
> By removing docutils and moving sphinx_rtd_theme before Sphinx in
> requirements.txt, the requirement of "docutils<0.17" can be met
> naturally.
>
> [1]: https://github.com/readthedocs/sphinx_rtd_theme/issues/1112
>
> Signed-off-by: Akira Yokosawa <akiyks@gmail.com>
> Cc: Mauro Carvalho Chehab <mchehab@kernel.org>
> ---
> Hi,
>
> It is better to keep requirements as minimal as possible.
> Let's leave the dependency to the sphinx_rtd_theme package.
>
> Changes in v1 [2] -> v2:
>
>     o Remove docutils entry.
>     o Move sphinx_rtd_theme to top.
>     o Adjust patch title.
>
> [2]: https://lore.kernel.org/linux-doc/974babfe-540f-40e4-38b3-ab294ba70ccc@gmail.com/

Applied, thanks.

jon

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2021-08-12 15:16 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-07-27 10:23 [PATCH] docs: Set upper limit of docutils (<0.17) Akira Yokosawa
2021-08-10  9:16 ` [PATCH v2] docs: sphinx-requirements: Move sphinx_rtd_theme to top Akira Yokosawa
2021-08-10  9:22   ` Mauro Carvalho Chehab
2021-08-12 15:16   ` Jonathan Corbet

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).