LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: "Yang, Libin" <Libin.Yang@amd.com>
To: "Greg KH" <greg@kroah.com>,
	"Volker Armin Hemmann" <volker.armin.hemmann@tu-clausthal.de>
Cc: <linux-kernel@vger.kernel.org>, <linux-usb@vger.kernel.org>,
	"Huang, Shane" <Shane.Huang@amd.com>
Subject: RE: 2.6.27: ehci bug with AMD 770nb/SB700 southbridge. usb lockup
Date: Thu, 30 Oct 2008 15:34:14 +0800	[thread overview]
Message-ID: <B90463BC30D2E446BA423D888DC85E50E8C0EB@sshaexmb1.amd.com> (raw)
In-Reply-To: <20081030055410.GB19035@kroah.com>

Thanks for reporting this bug. We are trying to reproduce this bug and
will look into it.

Thanks & Regards,
Libin

> -----Original Message-----
> From: Greg KH [mailto:greg@kroah.com]
> Sent: Thursday, October 30, 2008 1:54 PM
> To: Volker Armin Hemmann
> Cc: linux-kernel@vger.kernel.org; linux-usb@vger.kernel.org; Yang,
Libin;
> Cai, Crane
> Subject: Re: 2.6.27: ehci bug with AMD 770nb/SB700 southbridge. usb
lockup
> 
> On Thu, Oct 30, 2008 at 02:15:18AM +0100, Volker Armin Hemmann wrote:
> > Hi,
> >
> > I have a A770Crossfire board from Asrock.
> > With kernel 2.6.26.X and 2.6.27.[1,2,3,4] I have the following
problem
> that
> > makes usb mostly unusable.
> >
> > I have a 4 port hub attached. A logitech mouse receiver is inserted
into
> one
> > of its ports - it does not matter which one. Everything works fine.
> >
> > I turn on an external enclosure, which is either attached to one of
the
> > mainboards ports or the hub. Everything works for a couple of
seconds. I
> mount
> > the cdrom/harddisk partition and start copying a file - or just wait
a
> couple
> > of seconds.
> > USB completly locks up. First the mouse, then a bit later the file
> transfer
> > (so one was started) stops. Turning of the enclosure does not help,
> remving
> > the receiver and reinserting it, does not help, not using the hub
does
> not
> > help.
> > Only thing that brings back USB:
> > rmmod ehci_hcd
> > modprobe ehci-hcd
> >
> > rmmod and modprobe usb-storage does NOT help.
> >
> > after that I get another couple of seconds until it locks up again.
> >
> > If I modprobe ohci-hcd I get this:
> > with 2.6.26 and the mouse at ohci, enclosure at ehci, everything
works -
> but
> > gaming (with fglrx loaded) is impossible, since the mouse is
extremly
> jerky
> > (shared interrupts).
> > with 2.6.27 both mouse and enclose are driven by ohci - and copying
> works
> > without locking up. Trying to 'force' ehci for the enclosure makes
it
> lockup
> > again.
> >
> > This happens with kernel.org kernels+reiser4.
> 
> This chipset was known to have bugs in it, which I think we fixed
> already.  I have a laptop with this chipset and it can sustain large
> ammounts of USB data just fine with the 2.6.27 kernel series, so I
> wonder if something is wrong with your usb disk drive?
> 
> I've added some AMD developers on the CC: who helped develop the last
> fix for this chipset.  Libin, do you know of anything in the chipset
> that would cause these problems?
> 
> thanks,
> 
> greg k-h



  reply	other threads:[~2008-10-30  7:34 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-10-30  1:15 Volker Armin Hemmann
2008-10-30  5:54 ` Greg KH
2008-10-30  7:34   ` Yang, Libin [this message]
2008-10-30 16:19     ` Volker Armin Hemmann
2008-10-30 16:35     ` Volker Armin Hemmann
2008-11-07  8:27     ` Volker Armin Hemmann
2008-11-12  2:13       ` Yang, Libin
2008-11-12  5:49         ` Volker Armin Hemmann
2008-10-30 16:16   ` Volker Armin Hemmann

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=B90463BC30D2E446BA423D888DC85E50E8C0EB@sshaexmb1.amd.com \
    --to=libin.yang@amd.com \
    --cc=Shane.Huang@amd.com \
    --cc=greg@kroah.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-usb@vger.kernel.org \
    --cc=volker.armin.hemmann@tu-clausthal.de \
    --subject='RE: 2.6.27: ehci bug with AMD 770nb/SB700 southbridge. usb lockup' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).