LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Linus Torvalds <torvalds@linux-foundation.org>
To: Christian Brauner <christian.brauner@ubuntu.com>
Cc: Al Viro <viro@zeniv.linux.org.uk>,
	"Eric W. Biederman" <ebiederm@xmission.com>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 0/3 RESEND] namei: add follow_up_bind()
Date: Thu, 5 Apr 2018 09:28:56 -0700	[thread overview]
Message-ID: <CA+55aFzb7xzsOb=vfrwDFTX0SToOe1esgj2B1YNMPTDPUa8Nnw@mail.gmail.com> (raw)
In-Reply-To: <20180405105103.21572-1-christian.brauner@ubuntu.com>

On Thu, Apr 5, 2018 at 3:51 AM, Christian Brauner
<christian.brauner@ubuntu.com> wrote:
>
> This series adds:
> - follow_up_bind() to namei.{c,h}
> - switches fs/nfsd/vfs.c:follow_to_parent() to use follow_up_bind()
> - switches fs/devpts/inode.c:devpts_mntget() to use follow_up_bind()

Hmm. Seems fair enough to me, although I wonder how much this really
helps. It does get rid of a duplicate code pattern, but:

 4 files changed, 14 insertions(+), 5 deletions(-)

and while some of that is just the new comment, some of it is just "overhead".

It's also a bit odd how the new helper is marked "inline", but nobody
will inline it because it's not actually in the header file or any of
the isers in the same C file. So instead, it has to be exported. I
wonder if it should just be a trivial inline in <linux/namei.h>? Maybe
it originally was, and that's where the inline came from, and then
Christian decided to make it be by the regular "follow_up()" instead?

But with all that said, I certainly don't *mind* the patch series.

Al, I'm leaving this up to you, and expect to get it from your vfs
tree eventually. Or not.

                      Linus

  parent reply	other threads:[~2018-04-05 16:28 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-04-05 10:51 Christian Brauner
2018-04-05 10:51 ` [PATCH 1/3 " Christian Brauner
2018-04-05 10:51 ` [PATCH 2/3 RESEND] devpts: use follow_up_bind() helper Christian Brauner
2018-04-05 10:51 ` [PATCH 3/3 RESEND] nfsd: " Christian Brauner
2018-04-05 16:28 ` Linus Torvalds [this message]
2018-04-05 17:45   ` [PATCH 0/3 RESEND] namei: add follow_up_bind() Christian Brauner
2018-04-06 12:47     ` Christian Brauner

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CA+55aFzb7xzsOb=vfrwDFTX0SToOe1esgj2B1YNMPTDPUa8Nnw@mail.gmail.com' \
    --to=torvalds@linux-foundation.org \
    --cc=christian.brauner@ubuntu.com \
    --cc=ebiederm@xmission.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=viro@zeniv.linux.org.uk \
    --subject='Re: [PATCH 0/3 RESEND] namei: add follow_up_bind()' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).