LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Alexandre Courbot <gnurou@gmail.com>
To: Olliver Schinagl <oliver@schinagl.nl>
Cc: Olliver Schinagl <oliver+list@schinagl.nl>,
	Rob Herring <robh+dt@kernel.org>, Pawel Moll <pawel.moll@arm.com>,
	Mark Rutland <mark.rutland@arm.com>,
	Ian Campbell <ijc+devicetree@hellion.org.uk>,
	Kumar Gala <galak@codeaurora.org>,
	Linus Walleij <linus.walleij@linaro.org>,
	Dmitry Torokhov <dmitry.torokhov@gmail.com>,
	Bryan Wu <cooloney@gmail.com>, Richard Purdie <rpurdie@rpsys.net>,
	Robin Gong <b38343@freescale.com>,
	"Rafael J. Wysocki" <rafael.j.wysocki@intel.com>,
	Aaron Lu <aaron.lu@intel.com>,
	Mika Westerberg <mika.westerberg@linux.intel.com>,
	Grant Likely <grant.likely@linaro.org>,
	Wolfram Sang <wsa@the-dreams.de>,
	Alexander Shiyan <shc_work@mail.ru>,
	Jingoo Han <jg1.han@samsung.com>,
	"devicetree@vger.kernel.org" <devicetree@vger.kernel.org>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	"linux-gpio@vger.kernel.org" <linux-gpio@vger.kernel.org>,
	Linux Input <linux-input@vger.kernel.org>,
	"linux-leds@vger.kernel.org" <linux-leds@vger.kernel.org>
Subject: Re: [PATCH v1 2/4] gpio: add parameter to allow the use named gpios
Date: Fri, 23 Jan 2015 18:16:02 +0900	[thread overview]
Message-ID: <CAAVeFu+26pFFHyEfd=cwuCdtMurLWriaHKSixb-EMd_yWb0B1A@mail.gmail.com> (raw)
In-Reply-To: <54C01DD1.8040704@schinagl.nl>

On Thu, Jan 22, 2015 at 6:44 AM, Olliver Schinagl <oliver@schinagl.nl> wrote:
> Hey Alexandre,
>
> On 01/19/2015 05:04 AM, Alexandre Courbot wrote:
>>
>> On Wed, Jan 7, 2015 at 6:08 PM, Olliver Schinagl
>> <oliver+list@schinagl.nl> wrote:
>>>
>>> From: Olliver Schinagl <oliver@schinagl.nl>
>>>
>>> The gpio binding document says that new code should always use named
>>> gpios. Patch 40b73183 added support to parse a list of gpios from child
>>> nodes, but does not make it possible to use named gpios. This patch adds
>>> the con_id property and implements it is done in gpiolib.c, where the
>>> old-style of using unnamed gpios still works.
>>
>> This is absolutely correct - thanks for spotting this.
>>
>> <snip>
>> ... since it looks like this part has been mostly copy/pasted from
>> of_find_gpio(), can you add another patch that fixes it there as well?
>
> Yeah, since it has the same functionality, i copy pasted it. Wasn't sure if
> it was worth to macro it or anything. I've sent a v2 with that patch added
> to the mix :)
>>
>>
>> Also in the case of ACPI this will prove to be an incomplete lookup
>> since acpi_find_gpio() has an additional fallback if the named lookup
>> fails.
>
> I'm not very familiar (or at all) how ACPI falls into all of this, I'm just
> starting to get a hang of the DT, but since this is how the dts is being
> parsed, where is the relation here? Or did I misunderstand?

GPIO mappings can be provided by DT or by ACPI. In the latter case
there is a fallback method if the name does not match (see
acpi_find_gpio()). fwnode_get_named_gpiod() does not check it though,
so maybe we can just ignore that.

>> In that respect, I wonder if it would not be better for
>> devm_get_gpiod_from_child() to call of_find_gpio() and
>> acpi_find_gpio() (after making them non-static) followed by
>> gpiod_request() instead of calling fwnode_get_named_gpiod(). But in
>> that case it will have to do the OF/ACPI handling by itself.
>>
>> I'm not really sure about which way is better. I'd appreciate if you
>> could give a thought to a possible refactoring that would improve the
>> situation ; otherwise feel free to ignore what I have written above
>> and to duplicate the property name building code.
>
> I'm afraid I'm a little too inexperienced to follow exactly what you say ;)

Don't worry about it then, this patch is already an improvement. GPIO
mappings lookup from firmware has become kind of messy, and I'm just
trying to enroll people to clean it instead of doing it myself. ;)

  reply	other threads:[~2015-01-23  9:16 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-01-07  9:08 [PATCH v1 0/4] Let leds " Olliver Schinagl
2015-01-07  9:08 ` [PATCH v1 1/4] gpio:gpiolib: use static const char const * for a suffixes array Olliver Schinagl
2015-01-14 12:35   ` Linus Walleij
2015-01-07  9:08 ` [PATCH v1 2/4] gpio: add parameter to allow the use named gpios Olliver Schinagl
2015-01-08  0:15   ` Dmitry Torokhov
2015-01-14 12:36   ` Linus Walleij
2015-01-19  4:04   ` Alexandre Courbot
2015-01-21 21:44     ` Olliver Schinagl
2015-01-23  9:16       ` Alexandre Courbot [this message]
2015-01-07  9:08 ` [PATCH v1 3/4] leds: Let the binding document example for leds-gpio follow the gpio bindings Olliver Schinagl
2015-01-07 23:56   ` Dmitry Torokhov
2015-01-08  1:45   ` Rob Herring
2015-01-14 12:38   ` Linus Walleij
2015-01-07  9:08 ` [PATCH v1 4/4] leds: no longer use unnamed gpios Olliver Schinagl
2015-01-07 23:55   ` Dmitry Torokhov
2015-01-08  8:45     ` Olliver Schinagl
2015-01-08 14:40       ` Rob Herring
2015-01-08 22:12         ` Dmitry Torokhov
2015-01-14 12:45           ` Linus Walleij
2015-01-14 13:20             ` Olliver Schinagl
2015-01-19  3:43               ` Alexandre Courbot
2015-01-19  4:09                 ` Alexandre Courbot

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAAVeFu+26pFFHyEfd=cwuCdtMurLWriaHKSixb-EMd_yWb0B1A@mail.gmail.com' \
    --to=gnurou@gmail.com \
    --cc=aaron.lu@intel.com \
    --cc=b38343@freescale.com \
    --cc=cooloney@gmail.com \
    --cc=devicetree@vger.kernel.org \
    --cc=dmitry.torokhov@gmail.com \
    --cc=galak@codeaurora.org \
    --cc=grant.likely@linaro.org \
    --cc=ijc+devicetree@hellion.org.uk \
    --cc=jg1.han@samsung.com \
    --cc=linus.walleij@linaro.org \
    --cc=linux-gpio@vger.kernel.org \
    --cc=linux-input@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-leds@vger.kernel.org \
    --cc=mark.rutland@arm.com \
    --cc=mika.westerberg@linux.intel.com \
    --cc=oliver+list@schinagl.nl \
    --cc=oliver@schinagl.nl \
    --cc=pawel.moll@arm.com \
    --cc=rafael.j.wysocki@intel.com \
    --cc=robh+dt@kernel.org \
    --cc=rpurdie@rpsys.net \
    --cc=shc_work@mail.ru \
    --cc=wsa@the-dreams.de \
    --subject='Re: [PATCH v1 2/4] gpio: add parameter to allow the use named gpios' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).