LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Yang Shi <shy828301@gmail.com>
To: Baolin Wang <baolin.wang@linux.alibaba.com>
Cc: Andrew Morton <akpm@linux-foundation.org>,
	Linux MM <linux-mm@kvack.org>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 4/5] mm: migrate: Change to use bool type for 'page_was_mapped'
Date: Thu, 5 Aug 2021 10:34:42 -0700	[thread overview]
Message-ID: <CAHbLzkqX9E3NQiOmGxg5ovmjTqyMkeVPmS2pZYdmrhkfb+cT2g@mail.gmail.com> (raw)
In-Reply-To: <11d1f8fc954a83945930a5b11f47e00c063bdc1b.1628174413.git.baolin.wang@linux.alibaba.com>

On Thu, Aug 5, 2021 at 8:06 AM Baolin Wang
<baolin.wang@linux.alibaba.com> wrote:
>
> Change to use bool type for 'page_was_mapped' variable making it
> more readable.

Seems better to me. Reviewed-by: Yang Shi <shy828301@gmail.com>

>
> Signed-off-by: Baolin Wang <baolin.wang@linux.alibaba.com>
> ---
>  mm/migrate.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/mm/migrate.c b/mm/migrate.c
> index 6f048a8..0ab364f 100644
> --- a/mm/migrate.c
> +++ b/mm/migrate.c
> @@ -957,7 +957,7 @@ static int __unmap_and_move(struct page *page, struct page *newpage,
>                                 int force, enum migrate_mode mode)
>  {
>         int rc = -EAGAIN;
> -       int page_was_mapped = 0;
> +       bool page_was_mapped = false;
>         struct anon_vma *anon_vma = NULL;
>         bool is_lru = !__PageMovable(page);
>
> @@ -1060,7 +1060,7 @@ static int __unmap_and_move(struct page *page, struct page *newpage,
>                 VM_BUG_ON_PAGE(PageAnon(page) && !PageKsm(page) && !anon_vma,
>                                 page);
>                 try_to_migrate(page, 0);
> -               page_was_mapped = 1;
> +               page_was_mapped = true;
>         }
>
>         if (!page_mapped(page))
> --
> 1.8.3.1
>
>

  reply	other threads:[~2021-08-05 17:34 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-08-05 15:05 [PATCH 0/5] Some cleanup for page migration Baolin Wang
2021-08-05 15:05 ` [PATCH 1/5] mm: migrate: Move the page count validation to the proper place Baolin Wang
2021-08-05 15:17   ` Matthew Wilcox
2021-08-06  3:07     ` Baolin Wang
2021-08-07  2:02       ` Matthew Wilcox
2021-08-08  2:55         ` Baolin Wang
2021-08-08 10:26           ` Matthew Wilcox
2021-08-08 15:13             ` Baolin Wang
2021-08-08 16:01               ` Matthew Wilcox
2021-08-09  4:19                 ` Baolin Wang
2021-08-05 15:05 ` [PATCH 2/5] mm: migrate: Introduce a local variable to get the number of pages Baolin Wang
2021-08-05 17:42   ` Yang Shi
2021-08-05 15:05 ` [PATCH 3/5] mm: migrate: Fix the incorrect function name in comments Baolin Wang
2021-08-05 17:26   ` Yang Shi
2021-08-09 13:59   ` Alistair Popple
2021-08-05 15:05 ` [PATCH 4/5] mm: migrate: Change to use bool type for 'page_was_mapped' Baolin Wang
2021-08-05 17:34   ` Yang Shi [this message]
2021-08-05 15:06 ` [PATCH 5/5] mm: migrate: Remove redundant goto labels Baolin Wang
2021-08-05 19:54   ` Yang Shi
2021-08-06  3:20     ` Baolin Wang
2021-08-06 17:17       ` Yang Shi
2021-08-08  2:56         ` Baolin Wang

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CAHbLzkqX9E3NQiOmGxg5ovmjTqyMkeVPmS2pZYdmrhkfb+cT2g@mail.gmail.com \
    --to=shy828301@gmail.com \
    --cc=akpm@linux-foundation.org \
    --cc=baolin.wang@linux.alibaba.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --subject='Re: [PATCH 4/5] mm: migrate: Change to use bool type for '\''page_was_mapped'\''' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).