LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Vincent Guittot <vincent.guittot@linaro.org>
To: Peter Zijlstra <peterz@infradead.org>
Cc: Ingo Molnar <mingo@kernel.org>,
linux-kernel <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH] sched/fair: use RETRY_TASK in idle_balance
Date: Thu, 26 Apr 2018 15:11:02 +0200 [thread overview]
Message-ID: <CAKfTPtAT6khrY=3yfZdntG6ZEkYx9dg9yjEYtbcEcaxa3KU7DA@mail.gmail.com> (raw)
In-Reply-To: <20180426114956.GJ4064@hirez.programming.kicks-ass.net>
On 26 April 2018 at 13:49, Peter Zijlstra <peterz@infradead.org> wrote:
> On Thu, Apr 26, 2018 at 12:37:02PM +0200, Vincent Guittot wrote:
>> Use RETRY_TASK in idle_balance when we want select_task_rq() function to
>> rerun the complete task selection path
>>
>> Signed-off-by: Vincent Guittot <vincent.guittot@linaro.org>
>> ---
>> kernel/sched/fair.c | 2 +-
>> 1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c
>> index 0951d1c..ba49f83 100644
>> --- a/kernel/sched/fair.c
>> +++ b/kernel/sched/fair.c
>> @@ -9862,7 +9862,7 @@ static int idle_balance(struct rq *this_rq, struct rq_flags *rf)
>>
>> /* Is there a task of a high priority class? */
>> if (this_rq->nr_running != this_rq->cfs.h_nr_running)
>> - pulled_task = -1;
>> + pulled_task = RETRY_TASK;
>
> This doesn't make sense, pulled_task is an integer, not a task pointer.
> Also see how the caller in select_task_rq_fair() converts a negative
> into RETRY_TASK.
My goal was to try to make it a bit more readable about the meaning of
-1 but it fails with the type returned by idle_balance
next prev parent reply other threads:[~2018-04-26 13:11 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-04-26 10:37 Vincent Guittot
2018-04-26 11:49 ` Peter Zijlstra
2018-04-26 13:11 ` Vincent Guittot [this message]
2018-04-27 22:49 ` kbuild test robot
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to='CAKfTPtAT6khrY=3yfZdntG6ZEkYx9dg9yjEYtbcEcaxa3KU7DA@mail.gmail.com' \
--to=vincent.guittot@linaro.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@kernel.org \
--cc=peterz@infradead.org \
--subject='Re: [PATCH] sched/fair: use RETRY_TASK in idle_balance' \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).