LKML Archive on lore.kernel.org help / color / mirror / Atom feed
From: Ulf Hansson <ulf.hansson@linaro.org> To: Saravana Kannan <saravanak@google.com> Cc: Rob Herring <robh@kernel.org>, DTML <devicetree@vger.kernel.org>, "Rafael J . Wysocki" <rjw@rjwysocki.net>, Stephen Boyd <sboyd@kernel.org>, Dmitry Osipenko <digetx@gmail.com>, Linux PM <linux-pm@vger.kernel.org>, Linux Kernel Mailing List <linux-kernel@vger.kernel.org>, Linux ARM <linux-arm-kernel@lists.infradead.org> Subject: Re: [PATCH 1/2] of: property: fw_devlink: Rename 'node_not_dev' to 'optional_con_dev' Date: Wed, 1 Sep 2021 09:44:54 +0200 [thread overview] Message-ID: <CAPDyKFopTW=ZoB9FYJ-ozRZTnJDTT_gFtz0XDiU-weYb1Q9bkQ@mail.gmail.com> (raw) In-Reply-To: <CAGETcx868QWj0jMJ+U-eL62jT-LO_LTOw5EcwEKptfFOVa=A5A@mail.gmail.com> On Tue, 31 Aug 2021 at 19:31, Saravana Kannan <saravanak@google.com> wrote: > > On Tue, Aug 31, 2021 at 3:21 AM Ulf Hansson <ulf.hansson@linaro.org> wrote: > > > > In the struct supplier_bindings the member 'node_not_dev' is described as > > "The consumer node containing the property is never a device.", but that > > doesn't match the behaviour of the code in of_link_property(). > > > > To make the behaviour consistent with the description, let's rename the > > member to "optional_con_dev" and clarify the corresponding comment. > > > > Signed-off-by: Ulf Hansson <ulf.hansson@linaro.org> > > --- > > drivers/of/property.c | 9 +++++---- > > 1 file changed, 5 insertions(+), 4 deletions(-) > > > > diff --git a/drivers/of/property.c b/drivers/of/property.c > > index 6c028632f425..2babb1807228 100644 > > --- a/drivers/of/property.c > > +++ b/drivers/of/property.c > > @@ -1249,7 +1249,8 @@ static struct device_node *parse_##fname(struct device_node *np, \ > > * @parse_prop.index: For properties holding a list of phandles, this is the > > * index into the list > > * @optional: Describes whether a supplier is mandatory or not > > - * @node_not_dev: The consumer node containing the property is never a device. > > + * @optional_con_dev: The consumer node containing the property may not be a > > + * device, then try finding one from an ancestor node. > > Nak. This flag is not about "may not be". This is explicitly for > "never a device". It has to do with stuff like remote-endpoint which > is never listed under the root node of the device node. Your > documentation change is changing the meaning of the flag. Okay, fair enough. Although, as stated in the commit message this isn't the way code behaves. Shouldn't we at least make the behaviour consistent with the description of the 'node_not_dev' flag? Along the lines of the below patch then? From: Ulf Hansson <ulf.hansson@linaro.org> Date: Wed, 1 Sep 2021 09:28:03 +0200 Subject: [PATCH] of: property: fw_devlink: Fixup behaviour when 'node_not_dev' is set In the struct supplier_bindings the member 'node_not_dev' is described as "The consumer node containing the property is never a device.", but that is inconsistent with the behaviour of the code in of_link_property(), as it calls of_get_compat_node() that starts parsing for a compatible property, starting from the node it gets passed to it. Make the behaviour consistent with the description of the 'node_not_dev' flag, by passing the parent node to of_get_compat_node() instead. Signed-off-by: Ulf Hansson <ulf.hansson@linaro.org> --- drivers/of/property.c | 13 ++++++++++++- 1 file changed, 12 insertions(+), 1 deletion(-) diff --git a/drivers/of/property.c b/drivers/of/property.c index 6c028632f425..16ee017884b8 100644 --- a/drivers/of/property.c +++ b/drivers/of/property.c @@ -1075,6 +1075,17 @@ static struct device_node *of_get_compat_node(struct device_node *np) return np; } +static struct device_node *of_get_compat_node_parent(struct device_node *np) +{ + struct device_node *parent, *node; + + parent = of_get_parent(np); + node = of_get_compat_node(parent); + of_node_put(parent); + + return node; +} + /** * of_link_to_phandle - Add fwnode link to supplier from supplier phandle * @con_np: consumer device tree node @@ -1416,7 +1427,7 @@ static int of_link_property(struct device_node *con_np, const char *prop_name) struct device_node *con_dev_np; con_dev_np = s->node_not_dev - ? of_get_compat_node(con_np) + ? of_get_compat_node_parent(con_np) : of_node_get(con_np); matched = true; i++; -- 2.25.1 [...] Kind regards Uffe
next prev parent reply other threads:[~2021-09-01 7:45 UTC|newest] Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top 2021-08-31 10:21 [PATCH 1/2] of: property: fw_devlink: Rename 'node_not_dev' to 'optional_con_dev' Ulf Hansson 2021-08-31 17:30 ` Saravana Kannan 2021-09-01 7:44 ` Ulf Hansson [this message] 2021-09-01 20:56 ` Saravana Kannan 2021-09-01 21:26 ` Ulf Hansson 2021-09-01 22:06 ` Saravana Kannan 2021-09-01 22:24 ` Ulf Hansson 2021-09-02 0:25 ` Saravana Kannan
Reply instructions: You may reply publicly to this message via plain-text email using any one of the following methods: * Save the following mbox file, import it into your mail client, and reply-to-all from there: mbox Avoid top-posting and favor interleaved quoting: https://en.wikipedia.org/wiki/Posting_style#Interleaved_style * Reply using the --to, --cc, and --in-reply-to switches of git-send-email(1): git send-email \ --in-reply-to='CAPDyKFopTW=ZoB9FYJ-ozRZTnJDTT_gFtz0XDiU-weYb1Q9bkQ@mail.gmail.com' \ --to=ulf.hansson@linaro.org \ --cc=devicetree@vger.kernel.org \ --cc=digetx@gmail.com \ --cc=linux-arm-kernel@lists.infradead.org \ --cc=linux-kernel@vger.kernel.org \ --cc=linux-pm@vger.kernel.org \ --cc=rjw@rjwysocki.net \ --cc=robh@kernel.org \ --cc=saravanak@google.com \ --cc=sboyd@kernel.org \ /path/to/YOUR_REPLY https://kernel.org/pub/software/scm/git/docs/git-send-email.html * If your mail client supports setting the In-Reply-To header via mailto: links, try the mailto: linkBe sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox; as well as URLs for NNTP newsgroup(s).