LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Piotr Gluszenia Slawinski <curious@zjeby.dyndns.org>
To: Dmitry Torokhov <dmitry.torokhov@gmail.com>
Cc: linux-kernel@vger.kernel.org
Subject: Re: thinkpad 360Cs keyboard problem
Date: Tue, 12 Sep 2006 23:21:24 +0200 (CEST)	[thread overview]
Message-ID: <Pine.LNX.4.63.0609121950381.2685@Jerry.zjeby.dyndns.org> (raw)
In-Reply-To: <d120d5000609121012o684a098bx6bc2d497a17b1421@mail.gmail.com>

On Tue, 12 Sep 2006, Dmitry Torokhov wrote:

> On 9/12/06, Piotr Gluszenia Slawinski <curious@zjeby.dyndns.org> wrote:
>>  On Tue, 12 Sep 2006, Dmitry Torokhov wrote:
>> 
>> >  On 9/11/06, Piotr Gluszenia Slawinski <curious@zjeby.dyndns.org> wrote:
>> 
>> > >   kernel boots up fine, but keyboard is totally messed up,
>> > >   and locks up after some tries of use.
>> > 
>> >  Could you try describing the exact issues with the keyboard? Missing
>> >  keypresses, wrong keys reported, etc?
>>
>>  with prink enabled it prints series of 'unknown scancode'
>>  and keys are randomly messed up, and it changes, so like pressing b
>>  results with n, then space, then nothing at all.
>>  after some tries keyboard locks up completely.
>> 
>
> Are you loading a custom keymap by any chance? Could I please see
> dmesg with "i8042.debug log_buf_len=131072"?

no custom keymaps . init=/bin/bash :d
uhm, i don't get what you mean by this dmesg syntax :o
i should probably attach serial conole and send you whole output,
as now (as keyboard is unuseable) i can't scroll screen.

btw. serio: i8042 KBD port at 0x60,0x64 irq 1
is found.
also
input: AT Raw Set 2 keyboard as /class/input/input1
is reported

ah, i use gcc-4.1.1 to compile kernel .


-------------------- stuff below might be result of my ignorance

i just checked 2.2.27 kernel. it behaves quite identical to 2.4.33.3,
just after 'freeing unused kernel memory' it touches disk , and just
sits there. kepresses are echoed, and keyboard output is 
ok. i can reboot it by ctrl-alt-delete too .
when i boot it with 'fosh' shell commandline appears, but trying
to use any tool like bash, ls , etc results with signal 11.
tools are statically compiled against glibc-2.4 (compiled for 486 cpu
on gentoo)
busybox works fine.

on 2.4.33.3 kernel Xvesa (from kdrive package) complains
'set_thread_area failed when setting up thread-local storage'

cardmgr works fine aswell...(though was linked against different glibc)
  i guess there is some problem with math emulation and glibc,
as on 2.6.18 everything works just fine.

i recall few years ago i tried to make 386SX work on 2.4.20 , and 
there were problems with math emulation (some apps worked, some not)







  reply	other threads:[~2006-09-12 21:21 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2006-09-10  0:13 swsusp problem curious
2006-09-10  9:33 ` Rafael J. Wysocki
2006-09-10 19:24   ` curious
2006-09-10 19:27     ` Pavel Machek
2006-09-10 19:39       ` Piotr Gluszenia Slawinski
2006-09-10 19:49         ` Pavel Machek
2006-09-10 19:59           ` Piotr Gluszenia Slawinski
2006-09-11  0:54           ` Dmitry Torokhov
2006-09-11  8:04             ` Pavel Machek
2006-09-12  0:12             ` thinkpad 360Cs keyboard problem Piotr Gluszenia Slawinski
2006-09-12 14:05               ` Dmitry Torokhov
2006-09-12 14:24                 ` Piotr Gluszenia Slawinski
2006-09-12 17:12                   ` Dmitry Torokhov
2006-09-12 21:21                     ` Piotr Gluszenia Slawinski [this message]
2006-09-13  1:43                       ` Dmitry Torokhov
2006-09-10  9:40 ` swsusp problem Pavel Machek
2006-09-10 19:36   ` Piotr Gluszenia Slawinski

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=Pine.LNX.4.63.0609121950381.2685@Jerry.zjeby.dyndns.org \
    --to=curious@zjeby.dyndns.org \
    --cc=dmitry.torokhov@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --subject='Re: thinkpad 360Cs keyboard problem' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).