LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Jiri Kosina <jikos@jikos.cz>
To: Florin Iucha <florin@iucha.net>
Cc: Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	linux-usb-devel@lists.sourceforge.net,
	Adrian Bunk <bunk@stusta.de>,
	Alan Stern <stern@rowland.harvard.edu>,
	Trond Myklebust <trond.myklebust@fys.uio.no>
Subject: Re: heavy nfs[4]] causes fs badness Was: 2.6.20-rc4: known unfixed regressions (v2)
Date: Mon, 15 Jan 2007 01:14:09 +0100 (CET)	[thread overview]
Message-ID: <Pine.LNX.4.64.0701150109190.16747@twin.jikos.cz> (raw)
In-Reply-To: <20070114235816.GB6053@iucha.net>

On Sun, 14 Jan 2007, Florin Iucha wrote:

> All the testing was done via a ssh into the workstation.  The console 
> was left as booted into, with the gdm running.  The remote nfs4 
> directory was mounted on "/mnt". After copying the 60+ GB and testing 
> that the keyboard was still functioning, I did not reboot but stayed in 
> the same kernel and pulled the latest git then started bisecting.  

Hi Florin,

thanks a lot for the testing. Just to verify - what kernel is 'the same 
kernel' mentioned above? (just to isolate whether the problem is really 
somewhere between 2.6.19 and 2.6.20-rc2, as you stated in previous posts, 
or the situation has changed).

> After recompiling, I moved over to the workstation to reboot it, but the 
> keyboard was not functioning ;(

So this time the hang occured when the system was idle, not during the 
transfers, right?

> I ran "lsusb" and it displayed all the devices. "dmesg" did not show
> any oops, anything for that matter.  I have unplugged the keyboard and
> run "lsusb" again, but it hang.  I ran "ls /mnt" and it hang as well.
> Stracing "lsusb" showed it hang (entered the kernel) at opening the device
> that used to be the keyboard.  Stracing "ls /mnt" showed that it
> hang at "stat(/mnt)".  Both processes were in "D" state.  "ls /root"
> worked without problem, so it appears that crossing mountpoints causes
> some hang in the kernel.

Could you please do alt-sysrq-t (or "echo t > /proc/sysrq-trigger" via 
ssh, when your keyboard is dead) to see the calltraces of the processes 
which are stuck inside kernel?

You will probably get a lot of output after the sysrq, so please either 
put it somewhere on the web if possible, or just extract the interesting 
processes out of it (mainly the ones which are stuck).

Thanks,

-- 
Jiri Kosina

  reply	other threads:[~2007-01-15  0:15 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <20070109214431.GH24369@iucha.net>
     [not found] ` <Pine.LNX.4.44L0.0701101052310.3289-100000@iolanthe.rowland.org>
2007-01-14 22:57   ` [linux-usb-devel] " Florin Iucha
2007-01-14 23:58     ` heavy nfs[4]] causes fs badness Was: " Florin Iucha
2007-01-15  0:14       ` Jiri Kosina [this message]
2007-01-15  2:02         ` Florin Iucha
2007-01-15 15:58           ` Alan Stern
2007-01-24  3:04             ` Florin Iucha
2007-01-24 19:07               ` Alan Stern
2007-01-15  0:14       ` Trond Myklebust
2007-01-15  2:11       ` Horst H. von Brand
2007-01-15 15:46         ` Florin Iucha

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=Pine.LNX.4.64.0701150109190.16747@twin.jikos.cz \
    --to=jikos@jikos.cz \
    --cc=bunk@stusta.de \
    --cc=florin@iucha.net \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-usb-devel@lists.sourceforge.net \
    --cc=stern@rowland.harvard.edu \
    --cc=trond.myklebust@fys.uio.no \
    --subject='Re: heavy nfs[4]] causes fs badness Was: 2.6.20-rc4: known unfixed regressions (v2)' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).