LKML Archive on lore.kernel.org help / color / mirror / Atom feed
From: Matthew Wilcox <willy@infradead.org> To: Baolin Wang <baolin.wang@linux.alibaba.com> Cc: akpm@linux-foundation.org, linux-mm@kvack.org, linux-kernel@vger.kernel.org Subject: Re: [PATCH 1/5] mm: migrate: Move the page count validation to the proper place Date: Thu, 5 Aug 2021 16:17:35 +0100 [thread overview] Message-ID: <YQwBD55FZyoY+C5D@casper.infradead.org> (raw) In-Reply-To: <1f7e1d083864fbb17a20a9c8349d2e8b427e20a3.1628174413.git.baolin.wang@linux.alibaba.com> On Thu, Aug 05, 2021 at 11:05:56PM +0800, Baolin Wang wrote: > We've got the expected count for anonymous page or file page by > expected_page_refs() at the beginning of migrate_page_move_mapping(), > thus we should move the page count validation a little forward to > reduce duplicated code. Please add an explanation to the changelog for why it's safe to pull this out from under the i_pages lock. > Signed-off-by: Baolin Wang <baolin.wang@linux.alibaba.com> > --- > mm/migrate.c | 10 ++++------ > 1 file changed, 4 insertions(+), 6 deletions(-) > > diff --git a/mm/migrate.c b/mm/migrate.c > index 239b238..5559571 100644 > --- a/mm/migrate.c > +++ b/mm/migrate.c > @@ -386,11 +386,10 @@ int folio_migrate_mapping(struct address_space *mapping, > int expected_count = expected_page_refs(mapping, &folio->page) + extra_count; > long nr = folio_nr_pages(folio); > > - if (!mapping) { > - /* Anonymous page without mapping */ > - if (folio_ref_count(folio) != expected_count) > - return -EAGAIN; > + if (folio_ref_count(folio) != expected_count) > + return -EAGAIN; > > + if (!mapping) { > /* No turning back from here */ > newfolio->index = folio->index; > newfolio->mapping = folio->mapping; > @@ -404,8 +403,7 @@ int folio_migrate_mapping(struct address_space *mapping, > newzone = folio_zone(newfolio); > > xas_lock_irq(&xas); > - if (folio_ref_count(folio) != expected_count || > - xas_load(&xas) != folio) { > + if (xas_load(&xas) != folio) { > xas_unlock_irq(&xas); > return -EAGAIN; > } > -- > 1.8.3.1 > >
next prev parent reply other threads:[~2021-08-05 15:17 UTC|newest] Thread overview: 22+ messages / expand[flat|nested] mbox.gz Atom feed top 2021-08-05 15:05 [PATCH 0/5] Some cleanup for page migration Baolin Wang 2021-08-05 15:05 ` [PATCH 1/5] mm: migrate: Move the page count validation to the proper place Baolin Wang 2021-08-05 15:17 ` Matthew Wilcox [this message] 2021-08-06 3:07 ` Baolin Wang 2021-08-07 2:02 ` Matthew Wilcox 2021-08-08 2:55 ` Baolin Wang 2021-08-08 10:26 ` Matthew Wilcox 2021-08-08 15:13 ` Baolin Wang 2021-08-08 16:01 ` Matthew Wilcox 2021-08-09 4:19 ` Baolin Wang 2021-08-05 15:05 ` [PATCH 2/5] mm: migrate: Introduce a local variable to get the number of pages Baolin Wang 2021-08-05 17:42 ` Yang Shi 2021-08-05 15:05 ` [PATCH 3/5] mm: migrate: Fix the incorrect function name in comments Baolin Wang 2021-08-05 17:26 ` Yang Shi 2021-08-09 13:59 ` Alistair Popple 2021-08-05 15:05 ` [PATCH 4/5] mm: migrate: Change to use bool type for 'page_was_mapped' Baolin Wang 2021-08-05 17:34 ` Yang Shi 2021-08-05 15:06 ` [PATCH 5/5] mm: migrate: Remove redundant goto labels Baolin Wang 2021-08-05 19:54 ` Yang Shi 2021-08-06 3:20 ` Baolin Wang 2021-08-06 17:17 ` Yang Shi 2021-08-08 2:56 ` Baolin Wang
Reply instructions: You may reply publicly to this message via plain-text email using any one of the following methods: * Save the following mbox file, import it into your mail client, and reply-to-all from there: mbox Avoid top-posting and favor interleaved quoting: https://en.wikipedia.org/wiki/Posting_style#Interleaved_style * Reply using the --to, --cc, and --in-reply-to switches of git-send-email(1): git send-email \ --in-reply-to=YQwBD55FZyoY+C5D@casper.infradead.org \ --to=willy@infradead.org \ --cc=akpm@linux-foundation.org \ --cc=baolin.wang@linux.alibaba.com \ --cc=linux-kernel@vger.kernel.org \ --cc=linux-mm@kvack.org \ /path/to/YOUR_REPLY https://kernel.org/pub/software/scm/git/docs/git-send-email.html * If your mail client supports setting the In-Reply-To header via mailto: links, try the mailto: linkBe sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox; as well as URLs for NNTP newsgroup(s).