LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Christoph Hellwig <hch@infradead.org>
To: John Hubbard <jhubbard@nvidia.com>
Cc: Andrew Morton <akpm@linux-foundation.org>,
Matthew Wilcox <willy@infradead.org>,
LKML <linux-kernel@vger.kernel.org>,
linux-mm@kvack.org
Subject: Re: [PATCH 2/3] mm/gup: small refactoring: simplify try_grab_page()
Date: Mon, 9 Aug 2021 07:38:49 +0100 [thread overview]
Message-ID: <YRDNeZZQxUzbFxrQ@infradead.org> (raw)
In-Reply-To: <20210808235018.1924918-3-jhubbard@nvidia.com>
On Sun, Aug 08, 2021 at 04:50:17PM -0700, John Hubbard wrote:
> try_grab_page() does the same thing as try_grab_compound_head(...,
> refs=1, ...), just with a different API. So there is a lot of code
> duplication there.
>
> Change try_grab_page() to call try_grab_compound_head(), while keeping
> the API contract identical for callers.
>
> Signed-off-by: John Hubbard <jhubbard@nvidia.com>
> ---
> mm/gup.c | 29 ++---------------------------
> 1 file changed, 2 insertions(+), 27 deletions(-)
>
> diff --git a/mm/gup.c b/mm/gup.c
> index 5cb18b62921c..4be6f060fa0b 100644
> --- a/mm/gup.c
> +++ b/mm/gup.c
> @@ -203,33 +203,8 @@ static void put_compound_head(struct page *page, int refs, unsigned int flags)
> */
> bool __must_check try_grab_page(struct page *page, unsigned int flags)
> {
> + if (flags & (FOLL_GET | FOLL_PIN))
> + return try_grab_compound_head(page, 1, flags) != NULL;
>
> return true;
Nit: something like:
if (!(flags & (FOLL_GET | FOLL_PIN)))
return true;
return try_grab_compound_head(page, 1, flags) != NULL;
would be a little easier to read.
next prev parent reply other threads:[~2021-08-09 6:40 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-08-08 23:50 [PATCH 0/3] A few gup refactorings and documentation updates John Hubbard
2021-08-08 23:50 ` [PATCH 1/3] mm/gup: documentation corrections for gup/pup John Hubbard
2021-08-09 1:39 ` Matthew Wilcox
2021-08-09 6:46 ` John Hubbard
2021-08-10 21:19 ` John Hubbard
2021-08-08 23:50 ` [PATCH 2/3] mm/gup: small refactoring: simplify try_grab_page() John Hubbard
2021-08-09 6:38 ` Christoph Hellwig [this message]
2021-08-09 6:46 ` John Hubbard
2021-08-08 23:50 ` [PATCH 3/3] mm/gup: refactor and simplify try_get_page() John Hubbard
2021-08-09 6:29 ` Christoph Hellwig
2021-08-09 6:36 ` John Hubbard
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=YRDNeZZQxUzbFxrQ@infradead.org \
--to=hch@infradead.org \
--cc=akpm@linux-foundation.org \
--cc=jhubbard@nvidia.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=willy@infradead.org \
--subject='Re: [PATCH 2/3] mm/gup: small refactoring: simplify try_grab_page()' \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).