LKML Archive on
help / color / mirror / Atom feed
From: Steven Rostedt <>
To: Ingo Molnar <>
	Thomas Gleixner <>,
	Peter Zijlstra <>,
	Andrew Morton <>,
	David Miller <>,
	Linus Torvalds <>,
	Steven Rostedt <>
Subject: Re: [PATCH 1/2] ftrace: make dynamic ftrace more robust
Date: Wed, 22 Oct 2008 07:28:55 -0400 (EDT)	[thread overview]
Message-ID: <> (raw)
In-Reply-To: <>

On Wed, 22 Oct 2008, Steven Rostedt wrote:
> > 
> > > +					/* kprobes was not the fault */
> > > +					ftrace_kill_atomic();
> > 
> > while at it, ftrace_kill_atomic() is a misnomer.
> > 
> > Please use something more understandable and less ambigious, like 
> > "ftrace_turn_off()". Both 'kill' and 'atomic' are heavily laden phrases 
> > used for many other things in the kernel.

I agree with your "atomic" part but the 'kill' I do not. Yes, it is 
unfortunate that Unix used 'kill' to send signals. But the Unix name is 
the misnomer.  The problem with a "ftrace_turn_off" or anything similar, 
is that people will likely use it to temporarily disable ftrace when they 
need to do some sensitive code that they can not allow tracing on.
Then they will be confused when they can not find a "ftrace_turn_on()".

We already use "disable" to shut down ftrace and put it back into the 
"NOP" state. We have "stop" and "start" to stop function tracing quickly 
(just a bit is set, no conversion of code).

I figured "kill" is self explanatory. You use it when you want to kill 
ftrace and do not want it to come back. We have no "ftrace_resurrect" 
(well, not yet ;-)

I think most developers know the "kill" meaning. If you do not like the 
name, you can change it.

-- Steve

  reply	other threads:[~2008-10-22 11:29 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-10-21 16:40 [PATCH 0/2] ftrace: clean ups and sanity checks Steven Rostedt
2008-10-21 16:40 ` [PATCH 1/2] ftrace: make dynamic ftrace more robust Steven Rostedt
2008-10-22  6:53   ` Ingo Molnar
2008-10-22 11:07     ` Steven Rostedt
2008-10-22 11:28       ` Steven Rostedt [this message]
2008-10-22 11:47       ` Ingo Molnar
2008-10-22 12:07         ` Steven Rostedt
2008-10-21 16:40 ` [PATCH 2/2] ftrace: release functions from hash Steven Rostedt
2008-10-21 18:27   ` Steven Rostedt

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \ \ \ \ \ \ \ \ \ \ \
    --subject='Re: [PATCH 1/2] ftrace: make dynamic ftrace more robust' \

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).