LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Steven Rostedt <rostedt@goodmis.org>
To: Andrew Morton <akpm@linux-foundation.org>
Cc: linux-kernel@vger.kernel.org, mingo@elte.hu, tglx@linutronix.de,
peterz@infradead.org, torvalds@linux-foundation.org,
srostedt@redhat.com
Subject: Re: [PATCH 2/2] ftrace: nmi update statistics
Date: Thu, 30 Oct 2008 17:14:08 -0400 (EDT) [thread overview]
Message-ID: <alpine.DEB.1.10.0810301709510.21031@gandalf.stny.rr.com> (raw)
In-Reply-To: <20081030133852.11be15a8.akpm@linux-foundation.org>
On Thu, 30 Oct 2008, Andrew Morton wrote:
> On Thu, 30 Oct 2008 16:08:33 -0400
> Steven Rostedt <rostedt@goodmis.org> wrote:
>
> > This patch adds dynamic ftrace NMI update statistics to the
> > /debugfs/tracing/dyn_ftrace_total_info stat file.
> >
> > Signed-off-by: Steven Rostedt <srostedt@redhat.com>
> > ---
> > arch/x86/kernel/ftrace.c | 26 ++++++++++++++++++++++++--
> > kernel/trace/trace.c | 31 ++++++++++++++++++++++++-------
>
> No header files were modified, but ftrace_arch_read_dyn_info() should
> have been declared so that the above two compilation units see the
> declaration.
Ah, you caught me being lazy ;-) Since both also define the function, I
figured I'd be OK. But you are right, this would prevent bugs where the
two functions somehow got different parameters.
Will fix.
>
> >
> > Index: linux-tip.git/arch/x86/kernel/ftrace.c
> > ===================================================================
> > --- linux-tip.git.orig/arch/x86/kernel/ftrace.c 2008-10-30 15:30:12.000000000 -0400
> > +++ linux-tip.git/arch/x86/kernel/ftrace.c 2008-10-30 15:51:51.000000000 -0400
> > @@ -91,6 +91,19 @@ static int mod_code_write;
> > static void *mod_code_ip;
> > static void *mod_code_newcode;
> >
> > +static int nmi_wait_count;
> > +static atomic_t nmi_update_count;
>
> <the ATOMIC_INIT thing>
Hmm, this being arch specific code, is there such a thing as "atomic
declared as zero on x86 is OK" rule?
>
> > +int ftrace_arch_read_dyn_info(char *buf, int size)
> > +{
> > + int r;
> > +
> > + r = snprintf(buf, size, "%u %u",
> > + nmi_wait_count,
> > + atomic_read(&nmi_update_count));
> > + return r;
> > +}
>
> Yes, nmi_wait_count is an unsigned quantity. Might as well define it
> thusly?
OK.
>
> > static void ftrace_mod_code(void)
> > {
> > /*
> > @@ -109,8 +122,10 @@ void ftrace_nmi_enter(void)
> > atomic_inc(&in_nmi);
> > /* Must have in_nmi seen before reading write flag */
> > smp_mb();
> > - if (mod_code_write)
> > + if (mod_code_write) {
> > ftrace_mod_code();
> > + atomic_inc(&nmi_update_count);
> > + }
> > }
> >
> > void ftrace_nmi_exit(void)
> > @@ -122,8 +137,15 @@ void ftrace_nmi_exit(void)
> >
> > static void wait_for_nmi(void)
> > {
> > - while (atomic_read(&in_nmi))
> > + int waited = 0;
> > +
> > + while (atomic_read(&in_nmi)) {
> > + waited = 1;
> > cpu_relax();
> > + }
> > +
> > + if (waited)
> > + nmi_wait_count++;
> > }
> >
> > static int
> > Index: linux-tip.git/kernel/trace/trace.c
> > ===================================================================
> > --- linux-tip.git.orig/kernel/trace/trace.c 2008-10-30 15:18:45.000000000 -0400
> > +++ linux-tip.git/kernel/trace/trace.c 2008-10-30 15:51:51.000000000 -0400
> > @@ -2837,22 +2837,39 @@ static struct file_operations tracing_ma
> >
> > #ifdef CONFIG_DYNAMIC_FTRACE
> >
> > +#define DYN_INFO_BUF_SIZE 1023
> > +static char ftrace_dyn_info_buffer[DYN_INFO_BUF_SIZE+1];
>
> Could be made local to tracing_read_dyn_info().
>
>
> Could just be
>
> static char ftrace_dyn_info_buffer[1024];
>
> then use sizeof/ARRAY_SIZE elsewhere. I think this is a bit safer and
I think there's a defined macro for that... (goes look)
Yep! it's called ARRAY_SIZE(arr)
> more readable - the reader doesn't have to run around the code checking
> that the correct #define was used in both places.
Will fix.
Thanks,
-- Steve
next prev parent reply other threads:[~2008-10-30 21:14 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-10-30 20:08 [PATCH 0/2] ftrace: handle NMIs safely Steven Rostedt
2008-10-30 20:08 ` [PATCH 1/2] ftrace: nmi safe code modification Steven Rostedt
2008-10-30 20:32 ` Andrew Morton
2008-10-30 20:38 ` Ingo Molnar
2008-10-30 20:58 ` Steven Rostedt
2008-10-30 21:10 ` Andrew Morton
2008-10-31 4:03 ` [PATCH] ftrace: nmi safe code clean ups Steven Rostedt
2008-10-31 4:16 ` [PATCH] hardirq.h clean up Steven Rostedt
2008-10-31 9:30 ` Ingo Molnar
2008-10-31 13:36 ` [PATCH] ftrace: fix hardirq header for non ftrace archs Steven Rostedt
2008-11-03 10:04 ` Ingo Molnar
2008-10-31 9:28 ` [PATCH] ftrace: nmi safe code clean ups Ingo Molnar
2008-10-30 20:08 ` [PATCH 2/2] ftrace: nmi update statistics Steven Rostedt
2008-10-30 20:38 ` Andrew Morton
2008-10-30 21:14 ` Steven Rostedt [this message]
2008-10-30 20:34 ` [PATCH 0/2] ftrace: handle NMIs safely Ingo Molnar
2008-10-30 21:15 ` Steven Rostedt
2008-10-30 22:26 ` Ingo Molnar
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=alpine.DEB.1.10.0810301709510.21031@gandalf.stny.rr.com \
--to=rostedt@goodmis.org \
--cc=akpm@linux-foundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
--cc=peterz@infradead.org \
--cc=srostedt@redhat.com \
--cc=tglx@linutronix.de \
--cc=torvalds@linux-foundation.org \
--subject='Re: [PATCH 2/2] ftrace: nmi update statistics' \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).