LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Omar Sandoval <osandov@osandov.com>
To: Alexander Viro <viro@zeniv.linux.org.uk>,
linux-fsdevel@vger.kernel.org, linux-btrfs@vger.kernel.org,
ceph-devel@vger.kernel.org, linux-cifs@vger.kernel.org,
osd-dev@open-osd.org, linux-ext4@vger.kernel.org,
linux-f2fs-devel@lists.sourceforge.net,
fuse-devel@lists.sourceforge.net, cluster-devel@redhat.com,
jfs-discussion@lists.sourceforge.net, HPDD-discuss@ml01.01.org,
linux-nfs@vger.kernel.org, linux-nilfs@vger.kernel.org,
ocfs2-devel@oss.oracle.com, reiserfs-devel@vger.kernel.org,
v9fs-developer@lists.sourceforge.net, xfs@oss.sgi.com
Cc: linux-kernel@vger.kernel.org, Chris Mason <clm@fb.com>,
Josef Bacik <jbacik@fb.com>, David Sterba <dsterba@suse.cz>,
"Yan Zheng" <zyan@redhat.com>, Sage Weil <sage@redhat.com>,
Steve French <sfrench@samba.org>,
Boaz Harrosh <ooo@electrozaur.com>,
Benny Halevy <bhalevy@primarydata.com>, Jan Kara <jack@suse.cz>,
"Theodore Ts'o" <tytso@mit.edu>,
Andreas Dilger <adilger.kernel@dilger.ca>,
Jaegeuk Kim <jaegeuk@kernel.org>,
Changman Lee <cm224.lee@samsung.com>,
Miklos Szeredi <miklos@szeredi.hu>,
Steven Whitehouse <swhiteho@redhat.com>,
Dave Kleikamp <shaggy@kernel.org>,
Oleg Drokin <oleg.drokin@intel.com>,
Trond Myklebust <trond.myklebust@primarydata.com>,
Anna Schumaker <anna.schumaker@netapp.com>,
Ryusuke Konishi <konishi.ryusuke@lab.ntt.co.jp>,
Mark Fasheh <mfasheh@suse.com>, Joel Becker <jlbec@evilplan.org>,
Eric Van Hensbergen <ericvh@gmail.com>,
Ron Minnich <rminnich@sandia.gov>,
Latchesar Ionkov <lucho@ionkov.net>,
Dave Chinner <david@fromorbit.com>,
Omar Sandoval <osandov@osandov.com>
Subject: [RFC PATCH 0/5] Remove rw parameter from direct_IO()
Date: Mon, 16 Mar 2015 04:33:48 -0700 [thread overview]
Message-ID: <cover.1426502566.git.osandov@osandov.com> (raw)
Hi,
Al, here's some cleanup that you mentioned back in December that I got
around to (https://lkml.org/lkml/2014/12/15/28).
In summary, the rw parameter to a_ops->direct_IO() is redundant with
.type in struct iov_iter. Additionally, rw is inconsistently checked for
being a WRITE; some filesystems do rw == WRITE, others do rw & WRITE,
and others do both within the same function :) The distinction is that
swapout may OR in the ITER_BVEC flag in the rw passed to ->direct_IO(),
so the two are not equivalent (although this really only happens for
swap-over-NFS, but it's scary nonetheless). After looking through all of
these, it definitely looks like every check means for ANY write, not
just non-kernel writes.
So, the solution presented here is:
- Add a helper, iov_iter_rw(), which always returns either READ or
WRITE, no ITER_.* or REQ_.* nonsense mixed in. For consistency, the
return value is always checked for equality
- Get rid of all uses of rw in any implementations of direct_IO,
starting with the generic code
- Nuke the actual parameter and update the documentation
I decided to squish all of the filesystems together in patch 4 to avoid
inundating the mailing lists with 20+ mostly two-line patches, but I can
split those out if that's any better. Additionally, patch 1 pulls fs.h
into uio.h, which seems undesirable.
These were mostly just compile tested, with a couple of direct I/O
xfstests run on btrfs as quick sanity check, so getting some more eyes
on is probably a good thing. They should apply on top of v4.0-rc4.
Please comment away.
Thank you,
Omar Sandoval (5):
new helper: iov_iter_rw()
Remove rw from {,__,do_}blockdev_direct_IO()
Remove rw from dax_{do_,}io()
direct_IO: use iov_iter_rw() instead of rw everywhere
direct_IO: remove rw from a_ops->direct_IO()
Documentation/filesystems/Locking | 2 +-
Documentation/filesystems/vfs.txt | 2 +-
drivers/staging/lustre/lustre/llite/rw26.c | 22 ++++++++---------
fs/9p/vfs_addr.c | 2 +-
fs/affs/file.c | 9 +++----
fs/block_dev.c | 8 +++---
fs/btrfs/inode.c | 24 +++++++++---------
fs/ceph/addr.c | 3 +--
fs/cifs/file.c | 3 +--
fs/dax.c | 27 ++++++++++-----------
fs/direct-io.c | 39 ++++++++++++++----------------
fs/exofs/inode.c | 4 +--
fs/ext2/inode.c | 11 ++++-----
fs/ext3/inode.c | 14 +++++------
fs/ext4/ext4.h | 4 +--
fs/ext4/indirect.c | 25 ++++++++++---------
fs/ext4/inode.c | 28 ++++++++++-----------
fs/f2fs/data.c | 22 ++++++++---------
fs/fat/inode.c | 9 +++----
fs/fuse/file.c | 16 ++++++------
fs/gfs2/aops.c | 16 ++++++------
fs/hfs/inode.c | 8 +++---
fs/hfsplus/inode.c | 9 +++----
fs/jfs/inode.c | 8 +++---
fs/nfs/direct.c | 4 +--
fs/nilfs2/inode.c | 10 +++-----
fs/ocfs2/aops.c | 22 +++++++----------
fs/reiserfs/inode.c | 8 +++---
fs/udf/file.c | 3 +--
fs/udf/inode.c | 7 +++---
fs/xfs/xfs_aops.c | 12 ++++-----
include/linux/fs.h | 24 +++++++++---------
include/linux/nfs_fs.h | 2 +-
include/linux/uio.h | 10 ++++++++
mm/filemap.c | 4 +--
mm/page_io.c | 4 +--
36 files changed, 206 insertions(+), 219 deletions(-)
--
2.3.3
next reply other threads:[~2015-03-16 11:35 UTC|newest]
Thread overview: 15+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-03-16 11:33 Omar Sandoval [this message]
2015-03-16 11:33 ` [RFC PATCH 1/5] new helper: iov_iter_rw() Omar Sandoval
2015-03-16 17:36 ` Al Viro
2015-03-17 1:20 ` [RFC PATCH v2 " Omar Sandoval
2015-03-17 9:31 ` [RFC PATCH " David Sterba
2015-03-17 10:18 ` Omar Sandoval
2015-03-17 18:19 ` Al Viro
2015-03-17 21:04 ` [RFC PATCH v3 " Omar Sandoval
2015-03-18 13:42 ` David Sterba
2015-03-16 11:33 ` [RFC PATCH 2/5] Remove rw from {,__,do_}blockdev_direct_IO() Omar Sandoval
2015-03-16 11:33 ` [RFC PATCH 3/5] Remove rw from dax_{do_,}io() Omar Sandoval
2015-03-16 11:33 ` [RFC PATCH 4/5] direct_IO: use iov_iter_rw() instead of rw everywhere Omar Sandoval
2015-03-16 11:33 ` [RFC PATCH 5/5] direct_IO: remove rw from a_ops->direct_IO() Omar Sandoval
2015-03-16 18:15 ` [RFC PATCH 0/5] Remove rw parameter from direct_IO() Al Viro
2015-04-05 16:27 ` Al Viro
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=cover.1426502566.git.osandov@osandov.com \
--to=osandov@osandov.com \
--cc=HPDD-discuss@ml01.01.org \
--cc=adilger.kernel@dilger.ca \
--cc=anna.schumaker@netapp.com \
--cc=bhalevy@primarydata.com \
--cc=ceph-devel@vger.kernel.org \
--cc=clm@fb.com \
--cc=cluster-devel@redhat.com \
--cc=cm224.lee@samsung.com \
--cc=david@fromorbit.com \
--cc=dsterba@suse.cz \
--cc=ericvh@gmail.com \
--cc=fuse-devel@lists.sourceforge.net \
--cc=jack@suse.cz \
--cc=jaegeuk@kernel.org \
--cc=jbacik@fb.com \
--cc=jfs-discussion@lists.sourceforge.net \
--cc=jlbec@evilplan.org \
--cc=konishi.ryusuke@lab.ntt.co.jp \
--cc=linux-btrfs@vger.kernel.org \
--cc=linux-cifs@vger.kernel.org \
--cc=linux-ext4@vger.kernel.org \
--cc=linux-f2fs-devel@lists.sourceforge.net \
--cc=linux-fsdevel@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-nfs@vger.kernel.org \
--cc=linux-nilfs@vger.kernel.org \
--cc=lucho@ionkov.net \
--cc=mfasheh@suse.com \
--cc=miklos@szeredi.hu \
--cc=ocfs2-devel@oss.oracle.com \
--cc=oleg.drokin@intel.com \
--cc=ooo@electrozaur.com \
--cc=osd-dev@open-osd.org \
--cc=reiserfs-devel@vger.kernel.org \
--cc=rminnich@sandia.gov \
--cc=sage@redhat.com \
--cc=sfrench@samba.org \
--cc=shaggy@kernel.org \
--cc=swhiteho@redhat.com \
--cc=trond.myklebust@primarydata.com \
--cc=tytso@mit.edu \
--cc=v9fs-developer@lists.sourceforge.net \
--cc=viro@zeniv.linux.org.uk \
--cc=xfs@oss.sgi.com \
--cc=zyan@redhat.com \
--subject='Re: [RFC PATCH 0/5] Remove rw parameter from direct_IO()' \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).