LKML Archive on
help / color / mirror / Atom feed
From: Heiner Kallweit <>
To: "Oleksandr Natalenko" <>,
	"Toke Høiland-Jørgensen" <>
Cc: Dave Taht <>,
	"David S. Miller" <>,
	Jamal Hadi Salim <>,
	Cong Wang <>,
	Jiri Pirko <>,,
Subject: Re: CAKE and r8169 cause panic on upload in v4.19
Date: Fri, 26 Oct 2018 22:21:32 +0200	[thread overview]
Message-ID: <> (raw)
In-Reply-To: <>

On 26.10.2018 21:26, Oleksandr Natalenko wrote:
> Hello.
> I was excited regarding the fact that v4.19 introduced CAKE, so I've deployed it on my home router.
> I used this script of mine [1]:
> # bufferbloat enp3s0.100 20 20
> to do its job on the VLAN interface, where 20/20 ISP link is switched from the home switch. Basically, it just follows [2] with simple bandwidth restriction and egress mirroring using ifb.
> Then I thought it would be nice to run speedtest-cli on one of the computer in the home LAN, connected to this router. Download stage went fine, but immediately after upload started I've got a panic on the router: [3] (sorry, it is a photo, netconsole didn't work because, I assume, the panic happened in the networking code). I rebooted the router and tried once more, and got the same result, again during upload stage. Then I rebooted again, replaced CAKE script with my former HTB script, and after running speedtest-cli a couple of times there's no panic.
> Before running speedtest-cli I was using CAKE for a couple of days without generating much traffic just fine. It seems it crashes only if lots of traffic is generated with tools like this.
> My sysctl: [4] and ethtool -k: [5]
> So far, I've found something similar only here: [6] [7]. The common thing is r8169 driver in use, so, maybe, it is a driver issue, and CAKE is just happy to reveal it.
> If it is something known, please point me to a possible fix. If it is something new, I'm open to provide more info on your request, try patches etc (as usual).
It seems to be the same problem as described here:
As I commented in bugzilla, the GPF in dev_hard_start_xmit and the values of R12/R15 make me think
that a poisoned list pointer is accessed. It's so deep in the network stack that I can not really
imagine the network driver is to blame. One screenshot attached to the bug report shows that the
GPF also happened with the igb driver. Most likely we find out only once somebody spends effort
on bisecting the issue.
d4546c2509b1 ("net: Convert GRO SKB handling to list_head.") and some subsequent changes deal with
skb list processing, maybe the issue is related to one of these changes.

> Thanks.

  reply	other threads:[~2018-10-26 20:21 UTC|newest]

Thread overview: 11+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-10-26 19:26 Oleksandr Natalenko
2018-10-26 20:21 ` Heiner Kallweit [this message]
2018-10-26 20:25   ` Dave Taht
2018-10-26 20:54     ` Oleksandr Natalenko
2018-10-26 23:08       ` Dave Taht
2018-10-27 11:04         ` Oleksandr Natalenko
2018-10-27 13:43       ` Heiner Kallweit
2018-10-27 15:37         ` Oleksandr Natalenko
2018-10-28  4:44       ` David Miller
2018-10-28 12:22         ` Oleksandr Natalenko
2018-10-28 17:45           ` David Miller

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \ \ \ \ \ \ \ \ \ \ \ \
    --subject='Re: CAKE and r8169 cause panic on upload in v4.19' \

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).