LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Takashi Iwai <tiwai@suse.de>
To: Fernando Lopez-Lezcano <nando@ccrma.Stanford.EDU>
Cc: Ingo Molnar <mingo@elte.hu>,
	alsa-devel@alsa-project.org, linux-kernel@vger.kernel.org
Subject: Re: [alsa-devel] 2.6.26.[6|7] vs. rt11 vs. alsa (usb) midi
Date: Wed, 05 Nov 2008 08:43:47 +0100	[thread overview]
Message-ID: <s5h63n2mxcc.wl%tiwai@suse.de> (raw)
In-Reply-To: <1225695131.3772.12.camel@localhost.localdomain>

At Sun, 02 Nov 2008 22:52:11 -0800,
Fernando Lopez-Lezcano wrote:
> 
> On Wed, 2008-10-29 at 12:10 +0100, Takashi Iwai wrote:
> > At Tue, 28 Oct 2008 14:35:55 -0700,
> > Fernando Lopez-Lezcano wrote:
> > > 
> > > On Mon, 2008-10-27 at 09:13 +0100, Takashi Iwai wrote:
> > > > At Sat, 25 Oct 2008 19:46:27 -0700,
> > > > Fernando Lopez-Lezcano wrote:
> > > > > 
> > > > > Hi... anyone out there also having problem with this combination?
> > > > >    2.6.26.7 or 2.6.26.6 with 2.6.26.6-rt11 and alsa MIDI
> > > > > It looks to me like alsa midi is broken. 
> > > > > 
> > > > > Probably an interaction with the realtime kernel patch. A Fedora kernel
> > > > > based on 2.6.26.6 (2.6.26.6-49 on fc8) works fine, a very similarly
> > > > > patched kernel that includes the realtime patch does not. The
> > > > > configurations for both are almost the same (today I tried to change
> > > > > some of the most obvious differences and rebuild, with the same
> > > > > result). 
> > > > > 
> > > > > No problems with 2.6.24.7-rt21. 
> 
> (but on Fedora 9 I get X segfaults with it... so not really usable
> either)
> 
> > > > > Test: boot, login, plugin an external usb keyboard (Yamaha P250), it is
> > > > > recognized, use qjackctl alsa patchbay to connect it to kmidimon,
> > > > > kmidimon sees only _one_ midi message and that's it. Kmidimon can't be
> > > > > killed after that. 
> > > > 
> > > > What about other MIDI devices on other bus, e.g. an MPU401 on a PCI
> > > > soundcard or so?  There is a possibility of breakage in the USB driver
> > > > side, too.
> > > 
> > > I just tested an RME PCMCIA card + Multiface interface and it shows the
> > > same problem. No MIDI messages get through (but the LED in the Multiface
> > > blinks). Same hardware booted into 2.6.24.7-rt21 works fine. 
> > 
> > Then this should be in RT side.  There is no fundamental change
> > regarding rawmidi since some time ago...
> 
> Hmm, why do you say rawmidi? This is happening with the sequencer
> interface, AFAIK. 

Hmm, it's not impossible, if it's relevant with a timer interface,
although the sequencer core part has been fundamentally unchanged for
ages.

For sequencer issues, you can sort out by using it without rawmidi
interface.  For example, start aseqdump program in alsa-utils, and
send to that port via aplaymidi.


Takashi

  reply	other threads:[~2008-11-05  7:44 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-10-26  2:46 Fernando Lopez-Lezcano
2008-10-27  8:13 ` [alsa-devel] " Takashi Iwai
2008-10-28 21:35   ` Fernando Lopez-Lezcano
2008-10-29 11:10     ` Takashi Iwai
2008-11-03  6:52       ` Fernando Lopez-Lezcano
2008-11-05  7:43         ` Takashi Iwai [this message]
2008-11-06 22:53           ` Fernando Lopez-Lezcano

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=s5h63n2mxcc.wl%tiwai@suse.de \
    --to=tiwai@suse.de \
    --cc=alsa-devel@alsa-project.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@elte.hu \
    --cc=nando@ccrma.Stanford.EDU \
    --subject='Re: [alsa-devel] 2.6.26.[6|7] vs. rt11 vs. alsa (usb) midi' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).