LKML Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Takashi Iwai <tiwai@suse.de>
To: Jiri Kosina <jikos@jikos.cz>
Cc: Felipe Balbi <felipebalbi@users.sourceforge.net>,
	Andrew Morton <akpm@linux-foundation.org>,
	"Klaus S. Madsen" <ksm@hjernemadsen.org>,
	Theodore Tso <tytso@MIT.EDU>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>
Subject: Re: T61P sound issue
Date: Wed, 06 Feb 2008 08:10:21 +0100	[thread overview]
Message-ID: <s5hfxw6tvaa.wl%tiwai@suse.de> (raw)
In-Reply-To: <Pine.LNX.4.64.0802052207330.30873@twin.jikos.cz>

At Tue, 5 Feb 2008 22:16:08 +0100 (CET),
Jiri Kosina wrote:
> 
> [ added Takashi ]
> 
> On Tue, 5 Feb 2008, Felipe Balbi wrote:
> 
> > > > > > Could anyone make T61P's ICH8 sound controller to work properly?
> > Good that there's a lot of people using T61p, it's a good machine.
> > I'll upgrade my BIOS and try again the crappy sound.
> 
> I have just bought X61s, and it seems to have the very same soundcard as 
> your T61p does:
> 
> 00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
>         Subsystem: Lenovo Lenovo Thinkpad T61
>         Flags: bus master, fast devsel, latency 0, IRQ 17
>         Memory at fe220000 (64-bit, non-prefetchable) [size=16K]
>         Capabilities: [50] Power Management version 2
>         Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
>         Capabilities: [70] Express Unknown type IRQ 0
>         Capabilities: [100] Virtual Channel
>         Capabilities: [130] Unknown (5)
> 
> The sound also doesn't work with 2.6.24 (tried modprobing the 
> snd-hda-intel with 'model=thinkpad', didn't make any difference). The 
> mixer settings seem to be correct, but there is no sound.
> 
> Two strange things in alsamixer:
> 
> - it is possible to change volume of the "PCM" toggle, but it is missing 
>   the possibility to mute/unmute (the box with "MM"/"OO" simply isn't 
>   there)
> 
> - the "Headphone" toggle has "OO" as it is unmuted, but there is no 
>   possibility to change its volume, the volume box is completely missing

These are intentional.  There is no proper widgets (in HD-audio term,
corresponding to registers) to behave for these purposes.
On 2.6.25, you have additional "Master" volume and switch so that
these won't matter much, I hope.

> Takashi, if you need any other information which would help resolving 
> this, please let me know.

First, make sure that you unmuted the hardware volume / mute via
laptop keyboards.

If everything looks OK ("PCM" adjusted, "Headphone" and "Speaker"
unmuted) but still it doesn't work, it can be a driver problem.
If you set CONFIG_SND_HDA_POWER_SAVE, try to undefine it.

Or, try Ingo's patch Ted suggested.  (To be noted, this couldn't get
in to the mainline because this causes problems on other devices.
2.6.24-git already inclues this patch but with some workarounds.)


Takashi

  parent reply	other threads:[~2008-02-06  7:10 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-01-27 13:49 Felipe Balbi
2008-02-05  3:40 ` Andrew Morton
2008-02-05  3:43   ` Andrew Morton
2008-02-05 11:58     ` Takashi Iwai
2008-02-05 11:36   ` Klaus S. Madsen
2008-02-05 18:22     ` Andrew Morton
2008-02-05 21:04       ` Felipe Balbi
2008-02-05 21:16         ` Jiri Kosina
2008-02-05 21:25           ` Felipe Balbi
2008-02-06  2:25           ` Theodore Tso
2008-02-06  8:11             ` Jiri Kosina
2008-02-06 13:53               ` Theodore Tso
2008-02-06 13:56                 ` Jiri Kosina
2008-02-06 22:20                   ` Felipe Balbi
2008-02-06  7:10           ` Takashi Iwai [this message]
2008-02-06 10:06             ` Jiri Kosina
2008-02-06 22:33   ` ggriffin10
2008-02-06 22:40     ` Felipe Balbi
2008-02-07 12:06 Lukas Hejtmanek

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=s5hfxw6tvaa.wl%tiwai@suse.de \
    --to=tiwai@suse.de \
    --cc=akpm@linux-foundation.org \
    --cc=felipebalbi@users.sourceforge.net \
    --cc=jikos@jikos.cz \
    --cc=ksm@hjernemadsen.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=tytso@MIT.EDU \
    --subject='Re: T61P sound issue' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).