Netdev Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Kurt Kanzenbach <kurt@linutronix.de>
To: Andrew Lunn <andrew@lunn.ch>,
	Vivien Didelot <vivien.didelot@gmail.com>,
	Florian Fainelli <f.fainelli@gmail.com>,
	Richard Cochran <richardcochran@gmail.com>
Cc: "David S. Miller" <davem@davemloft.net>,
	Jakub Kicinski <kuba@kernel.org>,
	netdev@vger.kernel.org, Kurt Kanzenbach <kurt@linutronix.de>
Subject: [PATCH v1 0/2] ptp: Add generic header parsing function
Date: Thu, 23 Jul 2020 09:49:44 +0200	[thread overview]
Message-ID: <20200723074946.14253-1-kurt@linutronix.de> (raw)

Hi,

in order to reduce code duplication in the ptp code of DSA drivers, move the
header parsing function to ptp_classify. This way the Marvell and the hellcreek
drivers can share the same implementation. And probably more drivers can benefit
from it. Implemented as discussed [1] [2].

@DSA maintainers: Please, have a look the Marvell code. I don't have hardware to
test it. I've tested this series only on the Hirschmann switch.

Thanks,
Kurt

[1] - https://lkml.kernel.org/netdev/20200713140112.GB27934@hoboy/
[2] - https://lkml.kernel.org/netdev/20200720142146.GB16001@hoboy/

Kurt Kanzenbach (2):
  ptp: Add generic ptp v2 header parsing function
  net: dsa: mv88e6xxx: Use generic ptp header parsing function

 drivers/net/dsa/mv88e6xxx/Kconfig    |  1 +
 drivers/net/dsa/mv88e6xxx/hwtstamp.c | 59 ++++++----------------------
 include/linux/ptp_classify.h         | 38 ++++++++++++++++++
 net/core/ptp_classifier.c            | 30 ++++++++++++++
 4 files changed, 82 insertions(+), 46 deletions(-)

-- 
2.20.1


             reply	other threads:[~2020-07-23  7:50 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-07-23  7:49 Kurt Kanzenbach [this message]
2020-07-23  7:49 ` [PATCH v1 1/2] ptp: Add generic ptp v2 header parsing function Kurt Kanzenbach
2020-07-23 10:54   ` Kurt Kanzenbach
2020-07-23  7:49 ` [PATCH v1 2/2] net: dsa: mv88e6xxx: Use generic ptp " Kurt Kanzenbach
2020-07-23 17:11   ` Richard Cochran
2020-07-24  6:07     ` Kurt Kanzenbach
2020-07-23 17:08 ` [PATCH v1 0/2] ptp: Add generic " Richard Cochran
2020-07-24  6:25   ` Kurt Kanzenbach
2020-07-24 16:03     ` Richard Cochran
2020-07-25  7:04       ` Kurt Kanzenbach

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200723074946.14253-1-kurt@linutronix.de \
    --to=kurt@linutronix.de \
    --cc=andrew@lunn.ch \
    --cc=davem@davemloft.net \
    --cc=f.fainelli@gmail.com \
    --cc=kuba@kernel.org \
    --cc=netdev@vger.kernel.org \
    --cc=richardcochran@gmail.com \
    --cc=vivien.didelot@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).