Netdev Archive on lore.kernel.org help / color / mirror / Atom feed
From: Kurt Kanzenbach <kurt@linutronix.de> To: Richard Cochran <richardcochran@gmail.com> Cc: Andrew Lunn <andrew@lunn.ch>, Vivien Didelot <vivien.didelot@gmail.com>, Florian Fainelli <f.fainelli@gmail.com>, "David S. Miller" <davem@davemloft.net>, Jakub Kicinski <kuba@kernel.org>, Jiri Pirko <jiri@mellanox.com>, Ido Schimmel <idosch@mellanox.com>, Heiner Kallweit <hkallweit1@gmail.com>, Russell King <linux@armlinux.org.uk>, Grygorii Strashko <grygorii.strashko@ti.com>, Ivan Khoronzhuk <ivan.khoronzhuk@linaro.org>, Samuel Zou <zou_wei@huawei.com>, netdev@vger.kernel.org, Kurt Kanzenbach <kurt@linutronix.de> Subject: [PATCH v2 0/9] ptp: Add generic header parsing function Date: Mon, 27 Jul 2020 11:05:52 +0200 [thread overview] Message-ID: <20200727090601.6500-1-kurt@linutronix.de> (raw) Hi, in order to reduce code duplication in the ptp code of DSA, Ethernet and Phy drivers, move the header parsing function to ptp_classify. This way all drivers can share the same implementation. Implemented as discussed [1] [2] [3]. This is version two and contains more driver conversions. Richard, can you test with your hardware? I'll do the same e.g. on the bbb. Version 1 can be found here: * https://lkml.kernel.org/netdev/20200723074946.14253-1-kurt@linutronix.de/ Thanks, Kurt Changes since v1: * Fix Kconfig (Richard Cochran) * Include more drivers (Richard Cochran) [1] - https://lkml.kernel.org/netdev/20200713140112.GB27934@hoboy/ [2] - https://lkml.kernel.org/netdev/20200720142146.GB16001@hoboy/ [3] - https://lkml.kernel.org/netdev/20200723074946.14253-1-kurt@linutronix.de/ Kurt Kanzenbach (9): ptp: Add generic ptp v2 header parsing function ptp: Add generic ptp message type function net: dsa: mv88e6xxx: Use generic helper function mlxsw: spectrum_ptp: Use generic helper function ethernet: ti: am65-cpts: Use generic helper function ethernet: ti: cpts: Use generic helper function net: phy: dp83640: Use generic helper function ptp: ptp_ines: Use generic helper function ptp: Remove unused macro drivers/net/dsa/mv88e6xxx/hwtstamp.c | 59 +++---------- .../ethernet/mellanox/mlxsw/spectrum_ptp.c | 32 ++----- drivers/net/ethernet/ti/am65-cpts.c | 37 ++------ drivers/net/ethernet/ti/cpts.c | 37 ++------ drivers/net/phy/dp83640.c | 69 ++++----------- drivers/ptp/ptp_ines.c | 88 ++++++------------- include/linux/ptp_classify.h | 63 ++++++++++++- net/core/ptp_classifier.c | 30 +++++++ 8 files changed, 171 insertions(+), 244 deletions(-) -- 2.20.1
next reply other threads:[~2020-07-27 9:06 UTC|newest] Thread overview: 23+ messages / expand[flat|nested] mbox.gz Atom feed top 2020-07-27 9:05 Kurt Kanzenbach [this message] 2020-07-27 9:05 ` [PATCH v2 1/9] ptp: Add generic ptp v2 header parsing function Kurt Kanzenbach 2020-07-27 9:05 ` [PATCH v2 2/9] ptp: Add generic ptp message type function Kurt Kanzenbach 2020-07-27 9:05 ` [PATCH v2 3/9] net: dsa: mv88e6xxx: Use generic helper function Kurt Kanzenbach 2020-07-27 9:05 ` [PATCH v2 4/9] mlxsw: spectrum_ptp: " Kurt Kanzenbach 2020-07-27 13:00 ` Petr Machata 2020-07-28 13:29 ` Kurt Kanzenbach 2020-07-28 13:41 ` Kurt Kanzenbach 2020-07-28 21:06 ` Petr Machata 2020-07-29 10:02 ` Russell King - ARM Linux admin 2020-07-29 10:29 ` Kurt Kanzenbach 2020-07-29 13:49 ` Richard Cochran 2020-07-29 14:26 ` Kurt Kanzenbach 2020-07-29 14:07 ` Petr Machata 2020-07-29 13:22 ` Richard Cochran 2020-07-29 12:23 ` Grygorii Strashko 2020-07-27 9:05 ` [PATCH v2 5/9] ethernet: ti: am65-cpts: " Kurt Kanzenbach 2020-07-27 9:05 ` [PATCH v2 6/9] ethernet: ti: cpts: " Kurt Kanzenbach 2020-07-27 9:05 ` [PATCH v2 7/9] net: phy: dp83640: " Kurt Kanzenbach 2020-07-27 9:06 ` [PATCH v2 8/9] ptp: ptp_ines: " Kurt Kanzenbach 2020-07-27 9:06 ` [PATCH v2 9/9] ptp: Remove unused macro Kurt Kanzenbach 2020-07-29 0:47 ` [PATCH v2 0/9] ptp: Add generic header parsing function David Miller 2020-07-29 9:31 ` Kurt Kanzenbach
Reply instructions: You may reply publicly to this message via plain-text email using any one of the following methods: * Save the following mbox file, import it into your mail client, and reply-to-all from there: mbox Avoid top-posting and favor interleaved quoting: https://en.wikipedia.org/wiki/Posting_style#Interleaved_style * Reply using the --to, --cc, and --in-reply-to switches of git-send-email(1): git send-email \ --in-reply-to=20200727090601.6500-1-kurt@linutronix.de \ --to=kurt@linutronix.de \ --cc=andrew@lunn.ch \ --cc=davem@davemloft.net \ --cc=f.fainelli@gmail.com \ --cc=grygorii.strashko@ti.com \ --cc=hkallweit1@gmail.com \ --cc=idosch@mellanox.com \ --cc=ivan.khoronzhuk@linaro.org \ --cc=jiri@mellanox.com \ --cc=kuba@kernel.org \ --cc=linux@armlinux.org.uk \ --cc=netdev@vger.kernel.org \ --cc=richardcochran@gmail.com \ --cc=vivien.didelot@gmail.com \ --cc=zou_wei@huawei.com \ /path/to/YOUR_REPLY https://kernel.org/pub/software/scm/git/docs/git-send-email.html * If your mail client supports setting the In-Reply-To header via mailto: links, try the mailto: linkBe sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox; as well as URLs for NNTP newsgroup(s).