Netdev Archive on lore.kernel.org
help / color / mirror / Atom feed
* [PATCH] samples: bpf: offwaketime: define MAX_ENTRIES instead of a magic number
@ 2021-08-15 6:50 Muhammad Falak R Wani
2021-08-15 7:20 ` patchwork-bot+netdevbpf
0 siblings, 1 reply; 2+ messages in thread
From: Muhammad Falak R Wani @ 2021-08-15 6:50 UTC (permalink / raw)
To: Alexei Starovoitov, Daniel Borkmann, Andrii Nakryiko
Cc: Martin KaFai Lau, Song Liu, Yonghong Song, John Fastabend,
KP Singh, netdev, bpf, linux-kernel, Muhammad Falak R Wani
Define MAX_ENTRIES instead of using 10000 as a magic number in various
places.
Signed-off-by: Muhammad Falak R Wani <falakreyaz@gmail.com>
---
samples/bpf/offwaketime_kern.c | 9 +++++----
1 file changed, 5 insertions(+), 4 deletions(-)
diff --git a/samples/bpf/offwaketime_kern.c b/samples/bpf/offwaketime_kern.c
index 14b792915a9c..4866afd054da 100644
--- a/samples/bpf/offwaketime_kern.c
+++ b/samples/bpf/offwaketime_kern.c
@@ -20,6 +20,7 @@
})
#define MINBLOCK_US 1
+#define MAX_ENTRIES 10000
struct key_t {
char waker[TASK_COMM_LEN];
@@ -32,14 +33,14 @@ struct {
__uint(type, BPF_MAP_TYPE_HASH);
__type(key, struct key_t);
__type(value, u64);
- __uint(max_entries, 10000);
+ __uint(max_entries, MAX_ENTRIES);
} counts SEC(".maps");
struct {
__uint(type, BPF_MAP_TYPE_HASH);
__type(key, u32);
__type(value, u64);
- __uint(max_entries, 10000);
+ __uint(max_entries, MAX_ENTRIES);
} start SEC(".maps");
struct wokeby_t {
@@ -51,14 +52,14 @@ struct {
__uint(type, BPF_MAP_TYPE_HASH);
__type(key, u32);
__type(value, struct wokeby_t);
- __uint(max_entries, 10000);
+ __uint(max_entries, MAX_ENTRIES);
} wokeby SEC(".maps");
struct {
__uint(type, BPF_MAP_TYPE_STACK_TRACE);
__uint(key_size, sizeof(u32));
__uint(value_size, PERF_MAX_STACK_DEPTH * sizeof(u64));
- __uint(max_entries, 10000);
+ __uint(max_entries, MAX_ENTRIES);
} stackmap SEC(".maps");
#define STACKID_FLAGS (0 | BPF_F_FAST_STACK_CMP)
--
2.17.1
^ permalink raw reply [flat|nested] 2+ messages in thread
* Re: [PATCH] samples: bpf: offwaketime: define MAX_ENTRIES instead of a magic number
2021-08-15 6:50 [PATCH] samples: bpf: offwaketime: define MAX_ENTRIES instead of a magic number Muhammad Falak R Wani
@ 2021-08-15 7:20 ` patchwork-bot+netdevbpf
0 siblings, 0 replies; 2+ messages in thread
From: patchwork-bot+netdevbpf @ 2021-08-15 7:20 UTC (permalink / raw)
To: Muhammad Falak R Wani
Cc: ast, daniel, andrii, kafai, songliubraving, yhs, john.fastabend,
kpsingh, netdev, bpf, linux-kernel
Hello:
This patch was applied to bpf/bpf-next.git (refs/heads/master):
On Sun, 15 Aug 2021 12:20:13 +0530 you wrote:
> Define MAX_ENTRIES instead of using 10000 as a magic number in various
> places.
>
> Signed-off-by: Muhammad Falak R Wani <falakreyaz@gmail.com>
> ---
> samples/bpf/offwaketime_kern.c | 9 +++++----
> 1 file changed, 5 insertions(+), 4 deletions(-)
Here is the summary with links:
- samples: bpf: offwaketime: define MAX_ENTRIES instead of a magic number
https://git.kernel.org/bpf/bpf-next/c/d1bf7c4d5dea
You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2021-08-15 7:20 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-08-15 6:50 [PATCH] samples: bpf: offwaketime: define MAX_ENTRIES instead of a magic number Muhammad Falak R Wani
2021-08-15 7:20 ` patchwork-bot+netdevbpf
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).