Netdev Archive on lore.kernel.org
help / color / mirror / Atom feed
* [PATCH] net/mlx5: DR, Prefer kcalloc over open coded arithmetic
@ 2021-09-05 7:49 Len Baker
2021-09-20 21:19 ` Saeed Mahameed
2021-09-21 4:06 ` Kees Cook
0 siblings, 2 replies; 4+ messages in thread
From: Len Baker @ 2021-09-05 7:49 UTC (permalink / raw)
To: Saeed Mahameed, Leon Romanovsky, David S. Miller, Jakub Kicinski
Cc: Len Baker, Kees Cook, Yevgeny Kliteynik, Alex Vesker,
Erez Shitrit, Jianbo Liu, netdev, linux-rdma, linux-hardening,
linux-kernel
As noted in the "Deprecated Interfaces, Language Features, Attributes,
and Conventions" documentation [1], size calculations (especially
multiplication) should not be performed in memory allocator (or similar)
function arguments due to the risk of them overflowing. This could lead
to values wrapping around and a smaller allocation being made than the
caller was expecting. Using those allocations could lead to linear
overflows of heap memory and other misbehaviors.
So, refactor the code a bit to use the purpose specific kcalloc()
function instead of the argument size * count in the kzalloc() function.
[1] https://www.kernel.org/doc/html/v5.14/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
Signed-off-by: Len Baker <len.baker@gmx.com>
---
.../net/ethernet/mellanox/mlx5/core/steering/dr_action.c | 8 ++++++--
1 file changed, 6 insertions(+), 2 deletions(-)
diff --git a/drivers/net/ethernet/mellanox/mlx5/core/steering/dr_action.c b/drivers/net/ethernet/mellanox/mlx5/core/steering/dr_action.c
index 6475ba35cf6b..e8957dad3bb1 100644
--- a/drivers/net/ethernet/mellanox/mlx5/core/steering/dr_action.c
+++ b/drivers/net/ethernet/mellanox/mlx5/core/steering/dr_action.c
@@ -716,6 +716,7 @@ mlx5dr_action_create_mult_dest_tbl(struct mlx5dr_domain *dmn,
struct mlx5dr_action *action;
bool reformat_req = false;
u32 num_of_ref = 0;
+ u32 ref_act_cnt;
int ret;
int i;
@@ -724,11 +725,14 @@ mlx5dr_action_create_mult_dest_tbl(struct mlx5dr_domain *dmn,
return NULL;
}
- hw_dests = kzalloc(sizeof(*hw_dests) * num_of_dests, GFP_KERNEL);
+ hw_dests = kcalloc(num_of_dests, sizeof(*hw_dests), GFP_KERNEL);
if (!hw_dests)
return NULL;
- ref_actions = kzalloc(sizeof(*ref_actions) * num_of_dests * 2, GFP_KERNEL);
+ if (unlikely(check_mul_overflow(num_of_dests, 2u, &ref_act_cnt)))
+ goto free_hw_dests;
+
+ ref_actions = kcalloc(ref_act_cnt, sizeof(*ref_actions), GFP_KERNEL);
if (!ref_actions)
goto free_hw_dests;
--
2.25.1
^ permalink raw reply related [flat|nested] 4+ messages in thread
* Re: [PATCH] net/mlx5: DR, Prefer kcalloc over open coded arithmetic
2021-09-05 7:49 [PATCH] net/mlx5: DR, Prefer kcalloc over open coded arithmetic Len Baker
@ 2021-09-20 21:19 ` Saeed Mahameed
2021-09-21 4:06 ` Kees Cook
1 sibling, 0 replies; 4+ messages in thread
From: Saeed Mahameed @ 2021-09-20 21:19 UTC (permalink / raw)
To: len.baker, davem, kuba, leon
Cc: linux-rdma, Erez Shitrit, keescook, Yevgeny Kliteynik,
linux-kernel, Alex Vesker, linux-hardening, netdev, Jianbo Liu
On Sun, 2021-09-05 at 09:49 +0200, Len Baker wrote:
> As noted in the "Deprecated Interfaces, Language Features,
> Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or
> similar)
> function arguments due to the risk of them overflowing. This could
> lead
> to values wrapping around and a smaller allocation being made than
> the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
>
> So, refactor the code a bit to use the purpose specific kcalloc()
> function instead of the argument size * count in the kzalloc()
> function.
>
> [1]
> https://www.kernel.org/doc/html/v5.14/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
>
> Signed-off-by: Len Baker <len.baker@gmx.com>
applied to net-next-mlx5,
Thanks.
^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: [PATCH] net/mlx5: DR, Prefer kcalloc over open coded arithmetic
2021-09-05 7:49 [PATCH] net/mlx5: DR, Prefer kcalloc over open coded arithmetic Len Baker
2021-09-20 21:19 ` Saeed Mahameed
@ 2021-09-21 4:06 ` Kees Cook
2021-09-25 7:28 ` Len Baker
1 sibling, 1 reply; 4+ messages in thread
From: Kees Cook @ 2021-09-21 4:06 UTC (permalink / raw)
To: Len Baker
Cc: Saeed Mahameed, Leon Romanovsky, David S. Miller, Jakub Kicinski,
Yevgeny Kliteynik, Alex Vesker, Erez Shitrit, Jianbo Liu, netdev,
linux-rdma, linux-hardening, linux-kernel
On Sun, Sep 05, 2021 at 09:49:36AM +0200, Len Baker wrote:
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
>
> So, refactor the code a bit to use the purpose specific kcalloc()
> function instead of the argument size * count in the kzalloc() function.
>
> [1] https://www.kernel.org/doc/html/v5.14/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
>
> Signed-off-by: Len Baker <len.baker@gmx.com>
> ---
> .../net/ethernet/mellanox/mlx5/core/steering/dr_action.c | 8 ++++++--
> 1 file changed, 6 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/net/ethernet/mellanox/mlx5/core/steering/dr_action.c b/drivers/net/ethernet/mellanox/mlx5/core/steering/dr_action.c
> index 6475ba35cf6b..e8957dad3bb1 100644
> --- a/drivers/net/ethernet/mellanox/mlx5/core/steering/dr_action.c
> +++ b/drivers/net/ethernet/mellanox/mlx5/core/steering/dr_action.c
> @@ -716,6 +716,7 @@ mlx5dr_action_create_mult_dest_tbl(struct mlx5dr_domain *dmn,
> struct mlx5dr_action *action;
> bool reformat_req = false;
> u32 num_of_ref = 0;
> + u32 ref_act_cnt;
> int ret;
> int i;
>
> @@ -724,11 +725,14 @@ mlx5dr_action_create_mult_dest_tbl(struct mlx5dr_domain *dmn,
> return NULL;
> }
>
> - hw_dests = kzalloc(sizeof(*hw_dests) * num_of_dests, GFP_KERNEL);
> + hw_dests = kcalloc(num_of_dests, sizeof(*hw_dests), GFP_KERNEL);
> if (!hw_dests)
> return NULL;
>
> - ref_actions = kzalloc(sizeof(*ref_actions) * num_of_dests * 2, GFP_KERNEL);
> + if (unlikely(check_mul_overflow(num_of_dests, 2u, &ref_act_cnt)))
> + goto free_hw_dests;
> +
> + ref_actions = kcalloc(ref_act_cnt, sizeof(*ref_actions), GFP_KERNEL);
In the future, consider array3_size(), but this is fine too. :)
-Kees
> if (!ref_actions)
> goto free_hw_dests;
>
> --
> 2.25.1
>
--
Kees Cook
^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: [PATCH] net/mlx5: DR, Prefer kcalloc over open coded arithmetic
2021-09-21 4:06 ` Kees Cook
@ 2021-09-25 7:28 ` Len Baker
0 siblings, 0 replies; 4+ messages in thread
From: Len Baker @ 2021-09-25 7:28 UTC (permalink / raw)
To: Kees Cook
Cc: Len Baker, Saeed Mahameed, Leon Romanovsky, David S. Miller,
Jakub Kicinski, Yevgeny Kliteynik, Alex Vesker, Erez Shitrit,
Jianbo Liu, netdev, linux-rdma, linux-hardening, linux-kernel
Hi,
On Mon, Sep 20, 2021 at 09:06:35PM -0700, Kees Cook wrote:
> >
> > - ref_actions = kzalloc(sizeof(*ref_actions) * num_of_dests * 2, GFP_KERNEL);
> > + if (unlikely(check_mul_overflow(num_of_dests, 2u, &ref_act_cnt)))
> > + goto free_hw_dests;
> > +
> > + ref_actions = kcalloc(ref_act_cnt, sizeof(*ref_actions), GFP_KERNEL);
>
> In the future, consider array3_size(), but this is fine too. :)
Ok, thanks for the advise.
Regards,
Len
^ permalink raw reply [flat|nested] 4+ messages in thread
end of thread, other threads:[~2021-09-25 7:29 UTC | newest]
Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-09-05 7:49 [PATCH] net/mlx5: DR, Prefer kcalloc over open coded arithmetic Len Baker
2021-09-20 21:19 ` Saeed Mahameed
2021-09-21 4:06 ` Kees Cook
2021-09-25 7:28 ` Len Baker
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).