Netdev Archive on lore.kernel.org help / color / mirror / Atom feed
From: Jon Maloy <jmaloy@redhat.com> To: Menglong Dong <menglong8.dong@gmail.com> Cc: ying.xue@windriver.com, David Miller <davem@davemloft.net>, Jakub Kicinski <kuba@kernel.org>, LKML <linux-kernel@vger.kernel.org>, netdev <netdev@vger.kernel.org>, tipc-discussion@lists.sourceforge.net, Menglong Dong <dong.menglong@zte.com.cn>, Zeal Robot <zealci@zte.com.cn> Subject: Re: [PATCH net-next] net: tipc: fix FB_MTU eat two pages Date: Wed, 9 Jun 2021 03:34:33 -0400 [thread overview] Message-ID: <927af5e7-6194-d94e-1497-6b3dce26c583@redhat.com> (raw) In-Reply-To: <20210609025412.GA58348@www> On 6/8/21 10:54 PM, Menglong Dong wrote: > On Tue, Jun 08, 2021 at 06:37:38PM -0400, Jon Maloy wrote: >> > [...] >> I spent a little more time looking into this. I think the best we can do is >> to keep FB_MTU internal to msg.c, and then add an outline function to msg.c >> that can be used by bcast.c. The way it is used is never time critical. >> >> I also see that we could need a little cleanup around this. There is a >> redundant align() function that should be removed and replaced with the >> global ALIGN() macro. >> Even tipc_buf_acquire() should use this macro instead of the explicit method >> that is used now. >> In general, I stongly dislike conditional code, and it is not necessary in >> this function. If we redefine the non-crypto BUF_TAILROOM to 0 instead of 16 >> (it is not used anywhere else) we could get rid of this too. >> >> But I leave that to you. If you only fix the FB_MTU macro I am content. >> > Yeah, I think I can handle it, just leave it to me. > > (finger heart :/) > Menglong DongI It seems like I have been misleading you. It turns out that these messages *will* be sent out over the nework in some cases, i.e. at multicast/broadcast over an UDP bearer. So, what we need is two macros, one with the conditional crypto head/tailroom defined as you first suggested, and one that only use the non-crypto head/tailroom as we have been discussing now. The first one can be defined inside bcast.c, the latter inside msg.c. It might also be a good idea to give the macros more descriptive names, such as ONEPAGE_MTU in the broadcast version, and ONEPAGE_SKB in the node local version. Does that make sense? ///jon >
next prev parent reply other threads:[~2021-06-09 7:37 UTC|newest] Thread overview: 10+ messages / expand[flat|nested] mbox.gz Atom feed top 2021-06-04 7:44 [PATCH net-next] net: tipc: fix FB_MTU eat two pages menglong8.dong 2021-06-04 19:20 ` Jon Maloy 2021-06-05 1:28 ` Menglong Dong 2021-06-05 14:25 ` Jon Maloy 2021-06-06 14:40 ` Menglong Dong 2021-06-07 12:51 ` Menglong Dong 2021-06-08 22:37 ` Jon Maloy 2021-06-09 2:54 ` Menglong Dong 2021-06-09 7:34 ` Jon Maloy [this message] 2021-06-09 10:53 ` Menglong Dong
Reply instructions: You may reply publicly to this message via plain-text email using any one of the following methods: * Save the following mbox file, import it into your mail client, and reply-to-all from there: mbox Avoid top-posting and favor interleaved quoting: https://en.wikipedia.org/wiki/Posting_style#Interleaved_style * Reply using the --to, --cc, and --in-reply-to switches of git-send-email(1): git send-email \ --in-reply-to=927af5e7-6194-d94e-1497-6b3dce26c583@redhat.com \ --to=jmaloy@redhat.com \ --cc=davem@davemloft.net \ --cc=dong.menglong@zte.com.cn \ --cc=kuba@kernel.org \ --cc=linux-kernel@vger.kernel.org \ --cc=menglong8.dong@gmail.com \ --cc=netdev@vger.kernel.org \ --cc=tipc-discussion@lists.sourceforge.net \ --cc=ying.xue@windriver.com \ --cc=zealci@zte.com.cn \ /path/to/YOUR_REPLY https://kernel.org/pub/software/scm/git/docs/git-send-email.html * If your mail client supports setting the In-Reply-To header via mailto: links, try the mailto: linkBe sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox; as well as URLs for NNTP newsgroup(s).