Netdev Archive on lore.kernel.org
help / color / mirror / Atom feed
a saner API for allocating DMA addressable pages
2020-08-19 13:54 UTC (33+ messages)
` [PATCH 01/28] mm: turn alloc_pages into an inline function
` [PATCH 02/28] drm/exynos: stop setting DMA_ATTR_NON_CONSISTENT
` [PATCH 03/28] drm/nouveau/gk20a: "
` [PATCH 04/28] net/au1000-eth: stop using DMA_ATTR_NON_CONSISTENT
` [PATCH 05/28] media/v4l2: remove V4L2-FLAG-MEMORY-NON-CONSISTENT
` [PATCH 06/28] lib82596: move DMA allocation into the callers of i82596_probe
` [PATCH 07/28] 53c700: improve non-coherent DMA handling
` [PATCH 08/28] MIPS: make dma_sync_*_for_cpu a little less overzealous
` [PATCH 09/28] MIPS/jazzdma: remove the unused vdma_remap function
` [PATCH 10/28] MIPS/jazzdma: decouple from dma-direct
` [PATCH 11/28] dma-mapping: add (back) arch_dma_mark_clean for ia64
` [PATCH 12/28] dma-direct: remove dma_direct_{alloc,free}_pages
` [PATCH 13/28] dma-direct: lift gfp_t manipulation out of__dma_direct_alloc_pages
` [PATCH 14/28] dma-direct: use phys_to_dma_direct in dma_direct_alloc
` [PATCH 15/28] dma-direct: remove __dma_to_phys
` [PATCH 16/28] dma-direct: rename and cleanup __phys_to_dma
` [PATCH 17/28] dma-mapping: move dma_common_{mmap,get_sgtable} out of mapping.c
` [PATCH 18/28] dma-mapping: move the dma_declare_coherent_memory documentation
` [PATCH 19/28] dma-mapping: replace DMA_ATTR_NON_CONSISTENT with dma_{alloc,free}_pages
` [PATCH 20/28] sgiwd93: convert from dma_cache_sync to dma_sync_single_for_device
` [PATCH 21/28] hal2: "
` [PATCH 22/28] sgiseeq: "
` [PATCH 23/28] lib82596: "
` [PATCH 24/28] 53c700: "
` [PATCH 25/28] dma-mapping: remove dma_cache_sync
` [PATCH 26/28] dmapool: add dma_alloc_pages support
` [PATCH 27/28] nvme-pci: fix PRP pool size
` [PATCH 28/28] nvme-pci: use dma_alloc_pages backed dmapools
[PATCH V2 net-next 0/4] Enhance current features in ena driver
2020-08-19 13:43 UTC (5+ messages)
` [PATCH V2 net-next 1/4] net: ena: ethtool: use unsigned long for pointer arithmetics
` [PATCH V2 net-next 2/4] net: ena: ethtool: Add new device statistics
` [PATCH V2 net-next 3/4] net: ena: ethtool: add stats printing to XDP queues
` [PATCH V2 net-next 4/4] net: ena: xdp: add queue counters for xdp actions
[PATCH v3 0/7] net/ravb: Add support for explicit internal clock delay configuration
2020-08-19 13:43 UTC (8+ messages)
` [PATCH v3 1/7] dt-bindings: net: ethernet-controller: Add internal delay properties
` [PATCH v3 2/7] dt-bindings: net: renesas,ravb: Document internal clock "
` [PATCH v3 3/7] dt-bindings: net: renesas,etheravb: Convert to json-schema
` [PATCH v3 4/7] ravb: Split delay handling in parsing and applying
` [PATCH v3 5/7] ravb: Add support for explicit internal clock delay configuration
` [PATCH v3 6/7] arm64: dts: renesas: rcar-gen3: Convert EtherAVB to explicit delay handling
` [PATCH v3 7/7] arm64: dts: renesas: rzg2: "
[PATCH] arch: um: convert tasklets to use new tasklet_setup() API
2020-08-19 13:30 UTC (14+ messages)
` [PATCH] block: "
[PATCH net-next v2 0/2] net: dsa: loop: Expose VLAN table through devlink
2020-08-19 13:16 UTC (5+ messages)
` [PATCH net-next v2 1/2] net: dsa: loop: Configure VLANs while not filtering
` [PATCH net-next v2 2/2] net: dsa: loop: Return VLAN table size through devlink
[PATCH net-next 0/6] mvneta: introduce XDP multi-buffer support
2020-08-19 13:13 UTC (7+ messages)
` [PATCH net-next 1/6] xdp: introduce mb in xdp_buff/xdp_frame
` [PATCH net-next 2/6] xdp: initialize xdp_buff mb bit to 0 in all XDP drivers
` [PATCH net-next 3/6] net: mvneta: update mb bit before passing the xdp buffer to eBPF layer
` [PATCH net-next 4/6] xdp: add multi-buff support to xdp_return_{buff/frame}
` [PATCH net-next 5/6] net: mvneta: add multi buffer support to XDP_TX
` [PATCH net-next 6/6] net: mvneta: enable jumbo frames for XDP
[PATCH net-next v2 0/7] net-next: dsa: mt7530: add support for MT7531
2020-08-19 13:12 UTC (13+ messages)
` [PATCH net-next v2 5/7] net: dsa: mt7530: Add the support of MT7531 switch
` [PATCH net-next v2 7/7] arm64: dts: mt7622: add mt7531 dsa to bananapi-bpi-r64 board
[PATCH] macsec: Support 32bit PN netlink attribute for XPN links
2020-08-19 13:03 UTC (6+ messages)
[PATCH net-next RFC v2 00/13] Add devlink reload action option
2020-08-19 12:46 UTC (7+ messages)
` [PATCH net-next RFC v2 01/13] devlink: Add reload action option to devlink reload command
[PATCH v2] net: sctp: Fix negotiation of the number of data streams
2020-08-19 12:45 UTC
[PATCH v2] dt-bindings: net: renesas,ether: Improve schema validation
2020-08-19 12:45 UTC
[PATCH V1 net-next 0/3] Enhance current features in ena driver
2020-08-19 12:37 UTC (4+ messages)
` [PATCH V1 net-next 1/3] net: ena: ethtool: Add new device statistics
[PATCH] staging: wilc1000: Fix memleak in wilc_bus_probe
2020-08-19 11:54 UTC
[PATCH] staging: wilc1000: Fix memleak in wilc_sdio_probe
2020-08-19 11:50 UTC
[PATCH 00/49] DRM driver for Hikey 970
2020-08-19 11:46 UTC (4+ messages)
` [PATCH 01/49] staging: hikey9xx: Add hisilicon DRM driver for hikey960/970
` [PATCH 47/49] dts: add support for Hikey 970 DRM
` [PATCH 49/49] dt: display: Add binds for the DPE and DSI controller for Kirin 960/970
NETDEV WATCHDOG: WARNING: at net/sched/sch_generic.c:442 dev_watchdog
2020-08-19 11:31 UTC
KASAN: use-after-free Read in rtl_fw_do_work
2020-08-19 11:28 UTC (2+ messages)
[PATCH][next] ath11k: fix missing error check on call to ath11k_pci_get_user_msi_assignment
2020-08-19 11:14 UTC
[PATCH bpf] libbpf: fix map index used in error message
2020-08-19 11:05 UTC
ath11k: initialize wmi config based on hw_params
2020-08-19 11:05 UTC
[PATCH net-next 0/2] r8169: use napi_complete_done return value
2020-08-19 11:03 UTC (3+ messages)
` [PATCH net-next 1/2] "
` [PATCH net-next 2/2] r8169: remove member irq_enabled from struct rtl8169_private
[PATCH][next] ath11k: fix error check on return from call to ath11k_core_firmware_request
2020-08-19 10:57 UTC
ethernet/sfc/ warnings with 32-bit dma_addr_t
2020-08-19 10:37 UTC (2+ messages)
[PATCH 1/2] libnetlink: add rtattr_for_each_nested() iteration macro
2020-08-19 10:29 UTC (2+ messages)
` [PATCH 2/2] genl: ctrl: support dumping netlink policy
[PATCH] netlink: fix state reallocation in policy export
2020-08-19 10:22 UTC
Flaw in "random32: update the net random state on interrupt and activity"
2020-08-19 9:51 UTC (6+ messages)
[PATCH net-next 1/1] net/sched: Introduce skb hash classifier
2020-08-19 9:48 UTC (9+ messages)
xdp generic default option
2020-08-19 9:28 UTC
[PATCH bpf-next 0/6] Allow updating sockmap / sockhash from BPF
2020-08-19 9:24 UTC (7+ messages)
` [PATCH bpf-next 1/6] net: sk_msg: simplify sk_psock initialization
` [PATCH bpf-next 2/6] bpf: sockmap: merge sockmap and sockhash update functions
` [PATCH bpf-next 3/6] bpf: sockmap: call sock_map_update_elem directly
` [PATCH bpf-next 4/6] bpf: override the meaning of ARG_PTR_TO_MAP_VALUE for sockmap and sockhash
` [PATCH bpf-next 5/6] bpf: sockmap: allow update from BPF
` [PATCH bpf-next 6/6] selftests: bpf: test sockmap "
[PATCH bpf-next] tools/resolve_btfids: Fix sections with wrong alignment
2020-08-19 9:23 UTC
[PATCH net-next v2] Documentation/networking: update l2tp docs
2020-08-19 9:20 UTC
WARNING: suspicious RCU usage in tipc_l2_send_msg
2020-08-19 9:09 UTC (2+ messages)
[PATCH V2 net 0/3] Bug fixes for ENA ethernet driver
2020-08-19 9:04 UTC (4+ messages)
` [PATCH V2 net 1/3] net: ena: Prevent reset after device destruction
` [PATCH V2 net 2/3] net: ena: Change WARN_ON expression in ena_del_napi_in_range()
` [PATCH V2 net 3/3] net: ena: Make missed_tx stat incremental
[PATCH net-next] Documentation/networking: update l2tp docs
2020-08-19 9:01 UTC (3+ messages)
[PATCH 0/2] intel/xdp fixes for fliping rx buffer
2020-08-19 8:52 UTC (7+ messages)
` [Intel-wired-lan] "
` 答复: "
` 答复: "
[PATCH] cfg80211: switch from WARN() to pr_warn() in is_user_regdom_saved()
2020-08-19 8:46 UTC (2+ messages)
[PATCH v2] net: Stop warning about SO_BSDCOMPAT usage
2020-08-19 8:32 UTC
Use of genradix in sctp
2020-08-19 8:18 UTC (3+ messages)
[PATCH][next] ath11k: fix spelling mistake "moniter" -> "monitor"
2020-08-19 7:47 UTC
Is netif_rx_ni safe from interrupt context? (Re: [PATCH] batman-adv: bla: use netif_rx_ni when not in interrupt context)
2020-08-19 7:39 UTC
[PATCH] libceph: Convert to use the preferred fallthrough macro
2020-08-19 7:39 UTC (3+ messages)
[PATCH 00/28] Rid W=1 warnings in Wireless
2020-08-19 7:24 UTC (29+ messages)
` [PATCH 01/28] wireless: intersil: hostap: Mark 'freq_list' as __maybe_unused
` [PATCH 02/28] wireless: rsi_91x_main: Fix some kernel-doc issues
` [PATCH 03/28] wireless: rsi_91x_core: File header should not be kernel-doc
` [PATCH 04/28] wireless: marvell: libertas_tf: Demote non-conformant kernel-doc headers
` [PATCH 05/28] wireless: intel: dvm: Demote non-compliant "
` [PATCH 06/28] wireless: ti: wlcore: cmd: Fix some parameter description disparities
` [PATCH 07/28] wireless: marvell: libertas_tf: Fix a bunch of function doc formatting issues
` [PATCH 08/28] wireless: intel: iwlwifi: rs: Demote non-compliant kernel-doc headers
` [PATCH 09/28] wireless: intel: iwlegacy: debug: Demote seemingly unintentional kerneldoc header
` [PATCH 10/28] wireless: intel: iwlwifi: dvm: tx: Demote non-compliant kernel-doc headers
` [PATCH 11/28] wireless: intersil: hostap: hostap_ap: Mark 'txt' as __always_unused
` [PATCH 12/28] wireless: intel: iwlwifi: dvm: lib: Demote non-compliant kernel-doc headers
` [PATCH 13/28] wireless: st: cw1200: wsm: Remove 'dummy' variables
` [PATCH 14/28] wireless: marvell: libertas: Fix 'timer_list' stored private data related dot-rot
` [PATCH 15/28] wireless: mediatek: mt7601u: phy: Fix misnaming when documented function parameter 'dac'
` [PATCH 16/28] wireless: marvell: mwifiex: init: Move 'tos_to_tid_inv' to where it's used
` [PATCH 17/28] wireless: rsi: rsi_91x_main: Fix misnamed function parameter 'rx_pkt'
` [PATCH 18/28] wireless: rsi: rsi_91x_mac80211: Fix a few kerneldoc misdemeanours
` [PATCH 19/28] wireless: intel: iwlwifi: calib: Demote seemingly unintentional kerneldoc header
` [PATCH 20/28] wireless: rsi: rsi_91x_mgmt: Fix a myriad of documentation issues
` [PATCH 21/28] wireless: ath: wil6210: debugfs: Fix a couple of formatting issues in 'wil6210_debugfs_init'
` [PATCH 22/28] wireless: intel: iwlwifi: dvm: sta: Demote a bunch of nonconformant kernel-doc headers
` [PATCH 23/28] wireless: rsi: rsi_91x_hal: File header comments should not be kernel-doc
` [PATCH 24/28] wireless: intel: iwlegacy: 4965: Demote a bunch of nonconformant kernel-doc headers
` [PATCH 25/28] wireless: broadcom: brcmfmac: p2p: Deal with set but unused variables
` [PATCH 26/28] wireless: marvell: libertas: firmware: Fix misnaming for function param 'device'
` [PATCH 27/28] wireless: marvell: libertas_tf: if_usb: Fix function documentation formatting errors
` [PATCH 28/28] wireless: intersil: hostap_ioctl: Remove set but unused variable 'hostscan'
[PATCH] mwifiex: Clean up some err and dbg messages
2020-08-19 7:18 UTC
[PATCH net v5] net: xdp: account for layer 3 packets in generic skb handler
2020-08-19 7:07 UTC (3+ messages)
` [PATCH net v6] "
[PATCH] mwifiex: switch from 'pci_' to 'dma_' API
2020-08-19 7:01 UTC
INFO: task can't die in tls_sk_proto_close
2020-08-19 6:43 UTC
[PATCH bpf] bpf: verifier: check for packet data access based on target prog
2020-08-19 6:03 UTC (2+ messages)
[PATCH v4 0/9] ptp: Add generic helper functions
2020-08-19 6:00 UTC (7+ messages)
` [PATCH v4 2/9] ptp: Add generic ptp message type function
` [PATCH v4 3/9] net: dsa: mv88e6xxx: Use generic helper function
[PATCH iproute2-next] iproute2: ss: add support to expose various inet sockopts
2020-08-19 5:45 UTC (2+ messages)
[PATCH bpf-next 0/7] libbpf feature probing and sanitization improvements
2020-08-19 5:44 UTC (5+ messages)
` [PATCH bpf-next 1/7] libbpf: disable -Wswitch-enum compiler warning
[PATCH net-next 0/5] refactoring of ibmvnic code
2020-08-19 5:35 UTC (6+ messages)
` [PATCH net-next 1/5] ibmvnic: print caller in several error messages
` [PATCH net-next 2/5] ibmvnic: compare adapter->init_done_rc with more readable ibmvnic_rc_codes
` [PATCH net-next 3/5] ibmvnic: improve ibmvnic_init and ibmvnic_reset_init
` [PATCH net-next 4/5] ibmvnic: remove never executed if statement
` [PATCH net-next 5/5] ibmvnic: merge ibmvnic_reset_init and ibmvnic_init
[PATCH bpf-next 0/9] Add support for type-based and enum value-based CO-RE relocations
2020-08-19 5:32 UTC (5+ messages)
[PATCH v2 bpf-next 0/5] Add support for type-based and enum value-based CO-RE relocations
2020-08-19 5:28 UTC (6+ messages)
` [PATCH v2 bpf-next 1/5] libbpf: implement type-based CO-RE relocations support
` [PATCH v2 bpf-next 2/5] selftests/bpf: test TYPE_EXISTS and TYPE_SIZE CO-RE relocations
` [PATCH v2 bpf-next 3/5] selftests/bpf: add CO-RE relo test for TYPE_ID_LOCAL/TYPE_ID_TARGET
` [PATCH v2 bpf-next 4/5] libbpf: implement enum value-based CO-RE relocations
` [PATCH v2 bpf-next 5/5] selftests/bpf: add tests for ENUMVAL_EXISTS/ENUMVAL_VALUE relocations
[PATCH] net: bypass ->sendpage for slab pages
2020-08-19 5:19 UTC
[RFC PATCH net-next 0/6] devlink: Add device metric support
2020-08-19 4:30 UTC (5+ messages)
[PATCH v6 bpf-next 0/4] bpf: Populate bpffs with map and prog iterators
2020-08-19 4:27 UTC (5+ messages)
` [PATCH v6 bpf-next 1/4] bpf: Factor out bpf_link_by_id() helper
` [PATCH v6 bpf-next 2/4] bpf: Add BPF program and map iterators as built-in BPF programs
` [PATCH v6 bpf-next 3/4] bpf: Add kernel module with user mode driver that populates bpffs
` [PATCH v6 bpf-next 4/4] selftests/bpf: Add bpffs preload test
[PATCH v7 0/6] Introduce sendpage_ok() to detect misused sendpage in network related drivers
2020-08-19 4:22 UTC (6+ messages)
` [PATCH v7 1/6] net: introduce helper sendpage_ok() in include/linux/net.h
[PATCH bpf-next] libbpf: simplify the return expression of build_map_pin_path()
2020-08-19 4:15 UTC (2+ messages)
[net-next v3 0/4] devlink flash update overwrite mask
2020-08-19 3:54 UTC (5+ messages)
` [net-next v3 1/4] devlink: check flash_update parameter support in net core
` [net-next v3 3/4] devlink: introduce flash update overwrite mask
[PATCH net-next 00/18] GVE Driver v1.1.0 Features
2020-08-19 3:40 UTC (7+ messages)
` [PATCH net-next 05/18] gve: Add Gvnic stats AQ command and ethtool show/set-priv-flags
` [PATCH net-next 07/18] gve: Use link status register to report link status
` [PATCH net-next 18/18] gve: Bump version to 1.1.0
[PATCH -next] vdpa: Remove duplicate include
2020-08-19 2:55 UTC (2+ messages)
[PATCH net-next] SUNRPC: remove duplicate include
2020-08-19 2:49 UTC
[PATCH v1 0/2] To support the HFP WBS, a chip vendor may choose a particular
2020-08-19 2:48 UTC (2+ messages)
[PATCH net-next] net: ipa: remove duplicate include
2020-08-19 2:46 UTC
[PATCH net] net: gemini: Fix missing free_netdev() in error path of gemini_ethernet_port_probe()
2020-08-19 2:41 UTC (3+ messages)
[PATCH net v2] net: gemini: Fix missing free_netdev() in error path of gemini_ethernet_port_probe()
2020-08-19 2:33 UTC
[PATCH bpf-next] net-veth: add type safety to veth_xdp_to_ptr() and veth_ptr_to_xdp()
2020-08-19 2:00 UTC
[PATCH net-next v3 0/3] Add phylib support to smsc95xx
2020-08-19 1:58 UTC (3+ messages)
` [PATCH net-next v3 3/3] smsc95xx: add phylib support
[PATCH] gre6: Fix reception with IP6_TNL_F_RCV_DSCP_COPY
2020-08-19 1:53 UTC
page: next (older) | prev (newer) | latest
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).