Netdev Archive on lore.kernel.org
help / color / mirror / Atom feed
* net: dsa: mv88e6xxx: no multicasts rx'd after enabling hw time stamping
@ 2021-07-28 20:44 George McCollister
  2021-07-28 21:04 ` Andrew Lunn
  0 siblings, 1 reply; 7+ messages in thread
From: George McCollister @ 2021-07-28 20:44 UTC (permalink / raw)
  To: netdev; +Cc: Richard Cochran, Andrew Lunn

If I do the following on one of my mv88e6390 switch ports I stop
receiving multicast frames.
hwstamp_ctl -i lan0 -t 1 -r 12

Has anyone seen anything like this or have any ideas what might be
going on? Does anyone have PTP working on the mv88e6390?

I tried this but it doesn't help:
ip maddr add 01:xx:xx:xx:xx:xx dev lan0

I've tried sending 01:1B:19:00:00:00, 01:80:C2:00:00:0E as well as
other random ll multicast addresses. Nothing gets through once
hardware timestamping is switched on. The switch counters indicate
they're making it into the outward facing switch port but are not
being sent out the CPU facing switch port. I ran into this while
trying to get ptp4l to work.

I've tried kernels from 5.4 to net-next HEAD and I get the same results.

CONFIG_NET_DSA_MV88E6XXX_PTP is set to y in the kernel config.

Regards,
George McCollister

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2021-08-11 15:49 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-07-28 20:44 net: dsa: mv88e6xxx: no multicasts rx'd after enabling hw time stamping George McCollister
2021-07-28 21:04 ` Andrew Lunn
2021-07-28 22:24   ` Richard Cochran
2021-07-29 13:22     ` George McCollister
2021-07-29 13:42       ` Andrew Lunn
2021-08-11 15:49         ` George McCollister
2021-07-29 13:09   ` George McCollister

This is a public inbox, see mirroring instructions
on how to clone and mirror all data and code used for this inbox