Netdev Archive on lore.kernel.org
help / color / mirror / Atom feed
From: George McCollister <george.mccollister@gmail.com>
To: netdev <netdev@vger.kernel.org>
Cc: Richard Cochran <richardcochran@gmail.com>, Andrew Lunn <andrew@lunn.ch>
Subject: net: dsa: mv88e6xxx: no multicasts rx'd after enabling hw time stamping
Date: Wed, 28 Jul 2021 15:44:24 -0500	[thread overview]
Message-ID: <CAFSKS=Pv4qjfikHcvyycneAkQWTXQkKS_0oEVQ3JyE5UL6H=MQ@mail.gmail.com> (raw)

If I do the following on one of my mv88e6390 switch ports I stop
receiving multicast frames.
hwstamp_ctl -i lan0 -t 1 -r 12

Has anyone seen anything like this or have any ideas what might be
going on? Does anyone have PTP working on the mv88e6390?

I tried this but it doesn't help:
ip maddr add 01:xx:xx:xx:xx:xx dev lan0

I've tried sending 01:1B:19:00:00:00, 01:80:C2:00:00:0E as well as
other random ll multicast addresses. Nothing gets through once
hardware timestamping is switched on. The switch counters indicate
they're making it into the outward facing switch port but are not
being sent out the CPU facing switch port. I ran into this while
trying to get ptp4l to work.

I've tried kernels from 5.4 to net-next HEAD and I get the same results.

CONFIG_NET_DSA_MV88E6XXX_PTP is set to y in the kernel config.

Regards,
George McCollister

             reply	other threads:[~2021-07-28 20:44 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-07-28 20:44 George McCollister [this message]
2021-07-28 21:04 ` Andrew Lunn
2021-07-28 22:24   ` Richard Cochran
2021-07-29 13:22     ` George McCollister
2021-07-29 13:42       ` Andrew Lunn
2021-08-11 15:49         ` George McCollister
2021-07-29 13:09   ` George McCollister

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAFSKS=Pv4qjfikHcvyycneAkQWTXQkKS_0oEVQ3JyE5UL6H=MQ@mail.gmail.com' \
    --to=george.mccollister@gmail.com \
    --cc=andrew@lunn.ch \
    --cc=netdev@vger.kernel.org \
    --cc=richardcochran@gmail.com \
    --subject='Re: net: dsa: mv88e6xxx: no multicasts rx'\''d after enabling hw time stamping' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
on how to clone and mirror all data and code used for this inbox