Netdev Archive on lore.kernel.org
help / color / mirror / Atom feed
From: Biju Das <biju.das.jz@bp.renesas.com>
To: Sergei Shtylyov <sergei.shtylyov@gmail.com>,
"David S. Miller" <davem@davemloft.net>,
Jakub Kicinski <kuba@kernel.org>
Cc: Geert Uytterhoeven <geert+renesas@glider.be>,
Sergey Shtylyov <s.shtylyov@omprussia.ru>,
Adam Ford <aford173@gmail.com>, Andrew Lunn <andrew@lunn.ch>,
Yuusuke Ashizuka <ashiduka@fujitsu.com>,
Yoshihiro Shimoda <yoshihiro.shimoda.uh@renesas.com>,
"netdev@vger.kernel.org" <netdev@vger.kernel.org>,
"linux-renesas-soc@vger.kernel.org"
<linux-renesas-soc@vger.kernel.org>,
Chris Paterson <Chris.Paterson2@renesas.com>,
Biju Das <biju.das@bp.renesas.com>,
Prabhakar Mahadev Lad <prabhakar.mahadev-lad.rj@bp.renesas.com>
Subject: RE: [PATCH net-next v2 2/8] ravb: Add skb_sz to struct ravb_hw_info
Date: Tue, 3 Aug 2021 07:13:26 +0000 [thread overview]
Message-ID: <OS0PR01MB5922BC0F748E4FDC4FA904EB86F09@OS0PR01MB5922.jpnprd01.prod.outlook.com> (raw)
In-Reply-To: <58df29d2-c791-df23-994f-7d6176f79fb3@gmail.com>
Hi Sergei,
Thanks for the feedback.
> Subject: Re: [PATCH net-next v2 2/8] ravb: Add skb_sz to struct
> ravb_hw_info
>
> On 8/2/21 1:26 PM, Biju Das wrote:
>
> > The maximum descriptor size that can be specified on the reception
> > side for R-Car is 2048 bytes, whereas for RZ/G2L it is 8096.
> >
> > Add the skb_size variable to struct ravb_hw_info for allocating
> > different skb buffer sizes for R-Car and RZ/G2L using the
> netdev_alloc_skb function.
> >
> > Signed-off-by: Biju Das <biju.das.jz@bp.renesas.com>
> > Reviewed-by: Lad Prabhakar <prabhakar.mahadev-lad.rj@bp.renesas.com>
> > ---
> > v2:
> > * Incorporated Andrew and Sergei's review comments for making it
> smaller patch
> > and provided detailed description.
> > ---
> > drivers/net/ethernet/renesas/ravb.h | 1 +
> > drivers/net/ethernet/renesas/ravb_main.c | 10 ++++++----
> > 2 files changed, 7 insertions(+), 4 deletions(-)
> >
> > diff --git a/drivers/net/ethernet/renesas/ravb.h
> > b/drivers/net/ethernet/renesas/ravb.h
> > index cfb972c05b34..16d1711a0731 100644
> > --- a/drivers/net/ethernet/renesas/ravb.h
> > +++ b/drivers/net/ethernet/renesas/ravb.h
> > @@ -991,6 +991,7 @@ enum ravb_chip_id { struct ravb_hw_info {
> > enum ravb_chip_id chip_id;
> > int num_tx_desc;
> > + size_t skb_sz;
>
> Bad naming -- refers to software ISO hatdware, I suggest max_rx_len or
> s/th of that sort.
From the api description
* netdev_alloc_skb - allocate an skbuff for rx on a specific device
* @length: length to allocate
Since it allocates skbuff, I thought skb_sz (size of skb buffer) is a good name.
Is there any restriction in Linux, not to use skb_sz because of
"software ISO hardware" as you mentioned?
I may have chosen bad name because of this restriction.
Please correct me, if that is the case.
Regards,
Biju
next prev parent reply other threads:[~2021-08-03 7:13 UTC|newest]
Thread overview: 59+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-08-02 10:26 [PATCH net-next v2 0/8] Add Gigabit Ethernet driver support Biju Das
2021-08-02 10:26 ` [PATCH net-next v2 1/8] ravb: Add struct ravb_hw_info to driver data Biju Das
2021-08-02 15:02 ` Andrew Lunn
2021-08-02 20:42 ` Sergei Shtylyov
2021-08-03 5:57 ` Biju Das
2021-08-03 6:36 ` Biju Das
2021-08-04 19:27 ` Sergei Shtylyov
2021-08-04 20:27 ` Sergei Shtylyov
2021-08-09 12:06 ` Geert Uytterhoeven
2021-08-12 7:26 ` Biju Das
2021-08-12 7:58 ` Geert Uytterhoeven
2021-08-12 8:13 ` Biju Das
2021-08-17 11:24 ` Biju Das
2021-08-17 20:11 ` Sergey Shtylyov
2021-08-18 6:29 ` Biju Das
2021-08-18 10:11 ` Sergey Shtylyov
2021-08-18 10:23 ` Biju Das
2021-08-02 10:26 ` [PATCH net-next v2 2/8] ravb: Add skb_sz to struct ravb_hw_info Biju Das
2021-08-02 15:08 ` Andrew Lunn
2021-08-02 20:54 ` Sergei Shtylyov
2021-08-03 7:13 ` Biju Das [this message]
2021-08-02 10:26 ` [PATCH net-next v2 3/8] ravb: Add num_gstat_queue " Biju Das
2021-08-02 15:09 ` Andrew Lunn
2021-08-03 18:21 ` Sergei Shtylyov
2021-08-03 19:13 ` Biju Das
2021-08-03 19:22 ` Sergei Shtylyov
2021-08-03 19:47 ` Biju Das
2021-08-17 15:08 ` Biju Das
2021-08-02 10:26 ` [PATCH net-next v2 4/8] ravb: Add stats_len " Biju Das
2021-08-03 18:35 ` Sergei Shtylyov
2021-08-03 18:47 ` Biju Das
2021-08-03 19:20 ` Sergei Shtylyov
2021-08-02 10:26 ` [PATCH net-next v2 5/8] ravb: Add gstrings_stats and gstrings_size " Biju Das
2021-08-02 15:11 ` Andrew Lunn
2021-08-04 20:36 ` Sergei Shtylyov
2021-08-02 10:26 ` [PATCH net-next v2 6/8] ravb: Add net_features and net_hw_features " Biju Das
2021-08-02 15:12 ` Andrew Lunn
2021-08-05 19:07 ` Sergei Shtylyov
2021-08-05 19:18 ` Biju Das
2021-08-06 20:20 ` Sergei Shtylyov
2021-08-12 7:35 ` Biju Das
2021-08-06 20:31 ` Sergei Shtylyov
2021-08-02 10:26 ` [PATCH net-next v2 7/8] ravb: Add internal delay hw feature " Biju Das
2021-08-02 15:13 ` Andrew Lunn
2021-08-03 21:06 ` Sergei Shtylyov
2021-08-04 6:19 ` Biju Das
2021-08-03 21:12 ` Sergei Shtylyov
2021-08-04 5:13 ` Biju Das
2021-08-04 9:51 ` Sergey Shtylyov
2021-08-04 10:08 ` Biju Das
2021-08-04 10:34 ` Sergei Shtylyov
2021-08-04 10:20 ` Sergei Shtylyov
2021-08-04 10:32 ` Biju Das
2021-08-02 10:26 ` [PATCH net-next v2 8/8] ravb: Add tx_drop_cntrs " Biju Das
2021-08-02 15:14 ` Andrew Lunn
2021-08-04 20:50 ` Sergei Shtylyov
2021-08-17 15:47 ` Biju Das
2021-08-17 16:30 ` Sergey Shtylyov
2021-08-17 16:33 ` Biju Das
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=OS0PR01MB5922BC0F748E4FDC4FA904EB86F09@OS0PR01MB5922.jpnprd01.prod.outlook.com \
--to=biju.das.jz@bp.renesas.com \
--cc=Chris.Paterson2@renesas.com \
--cc=aford173@gmail.com \
--cc=andrew@lunn.ch \
--cc=ashiduka@fujitsu.com \
--cc=biju.das@bp.renesas.com \
--cc=davem@davemloft.net \
--cc=geert+renesas@glider.be \
--cc=kuba@kernel.org \
--cc=linux-renesas-soc@vger.kernel.org \
--cc=netdev@vger.kernel.org \
--cc=prabhakar.mahadev-lad.rj@bp.renesas.com \
--cc=s.shtylyov@omprussia.ru \
--cc=sergei.shtylyov@gmail.com \
--cc=yoshihiro.shimoda.uh@renesas.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).